Results 1 to 5 of 5

Thread: via venezia not pumping water

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Posts
    6

    via venezia not pumping water

    hi,

    my saeco via venezia is not pumping water, through group head or steam wand. the pump still makes a noise and can still make steam.

    has anyone had this problem, would it be blocked somewhere or do i need a new pump.

    thanks



  2. #2
    .
    Join Date
    Aug 2004
    Posts
    2,312

    Re: via venezia not pumping water

    Sorry but afraid its off to the techie.

    Cant diagnose intangibles sight unseen.

    Regardz,
    Attilio

  3. #3
    Junior Member
    Join Date
    Mar 2011
    Posts
    13

    Re: via venezia not pumping water

    The only reason am having a bash at this is because Ive had Venizias (2) over the last 8~9 years. True, prolly a techie visit, but when I cleaned mine some time back, like having the take-up tube/filter out of the tank...I was cleaning everything... it took a while to get the little pump primed.
    From memory, I may have tried opening the steam knob while having the pump turned on. Once again, from memory, this MAY have allowed easier suck/flow, and effectively primed the system. Maybe give that a try.

  4. #4
    Junior Member
    Join Date
    Mar 2011
    Posts
    15

    Re: via venezia not pumping water

    Had the same problem.

    Pump wouldnt prime when it was allowed to run out of water (old machine)

    Opened up the machine by taking out the four screws at the back. Remove one end of the pipe that runs between the pump and the group head (do this while the machine is cold). Run the pump till it primes, you will hear the pump get quieter. Refit hose and away you go

    Hope this helps

  5. #5
    Junior Member
    Join Date
    Mar 2017
    Posts
    1
    You need to reprime the pump. It's easy. Turn the machine on but leave brew and steam switches OFF. Place a cup under the steaming wand. Open the steaming valve. When the valve is opened but the boiler is not heated for steaming, the pump kicks on and primes the pump. When the water from the wand is flowing in a continuous stream (3-5 seconds), shut the steam valve. You may now heat the water to steam or brew.


Similar Threads

  1. EM5900 pumping water straight into the tray
    By platinum in forum Brewing Equipment - Entry level (sub $500)
    Replies: 7
    Last Post: 15th September 2012, 02:32 PM
  2. Gaggia Classic not pumping water
    By geek in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 5
    Last Post: 14th August 2009, 02:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •