Results 1 to 8 of 8
Like Tree7Likes
  • 1 Post By madjaffa
  • 5 Post By LeroyC
  • 1 Post By Barry O'Speedwagon

Thread: Otto / Little Guy Espresso Maker + Induction top. Induction issues

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Location
    Port Macquarie, NSW
    Posts
    8

    Otto / Little Guy Espresso Maker + Induction top. Induction issues

    Hey guys,

    Was wondering if anyone has had this issue with the induction top for the Otto/Little Guy and know of a fix:

    Machine turned on as per instructions.
    - Power light and Otto light comes on

    Machine brews for approximately 2:30.
    - At some point the "hot" light comes on.
    - Otto top beeps, and two extra lights come on, pretty sure they are the first and last lights for stove-top mode (see attached picture).
    - At this point I believe the machine has stopped providing heat and is in some sort of bugged/error mode.
    - Otto stays like this for about a minute before shutting off, all lights turn off except the "hot" light.

    Machine is barely on long enough to warm the water.

    Thanks,

    G
    Attached Images Attached Images

  2. #2
    Senior Member
    Join Date
    Nov 2014
    Location
    Adelaide, SA
    Posts
    130
    Is the induction cooktop the one specifically designed for the Little Guy?

    Regards,

    Matt

  3. #3
    Junior Member
    Join Date
    Oct 2011
    Location
    Port Macquarie, NSW
    Posts
    8
    Quote Originally Posted by MattyRay View Post
    Is the induction cooktop the one specifically designed for the Little Guy?

    Regards,

    Matt
    Ya it's the one that came with it.
    MattyRay likes this.

  4. #4
    Junior Member
    Join Date
    Sep 2015
    Posts
    1
    Don't know if you still get these posts or have the machine, but check that the power cord hasn't come loose under the induction plate. Push it right in again and it may work well.

  5. #5
    Senior Member LeroyC's Avatar
    Join Date
    Sep 2013
    Location
    Woodend, New Zealand
    Posts
    1,341

    Otto / Little Guy Espresso Maker + Induction top. Induction issues

    I'd imagine 'madjaffa' sorted this a long time ago seeing as this thread is 9 months old.

    A bit of general info for Little Guy owners:

    I was actually talking to Craig Hiron a couple of weeks ago and he mentioned the troublesome induction stoves. They had 2 production runs I think it was that had high failure rates. They were quite open about it once the scale became apparent, and you can find some info on their Facebook page. They replaced all the faulty ones (to their best knowledge anyway), and have actually pretty much done a total redesign of this product ready for the re-launch of The Little Guy later this year.

  6. #6
    Junior Member
    Join Date
    Oct 2011
    Location
    Port Macquarie, NSW
    Posts
    8
    Definitely wasn't a power chord plug issue. I have since given the device back to my uncle.

    I would guess it had a wiring or chip failure as it slowly got worse. Only played up every now and then, with the old turn it off and on again fixing it, until it just stopped working as intended.

    Thanks anyways guys.

  7. #7
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,108
    Quote Originally Posted by madjaffa View Post
    Definitely wasn't a power chord .
    Rock guitarist by any chance?
    MattyRay likes this.

  8. #8
    Junior Member
    Join Date
    Oct 2011
    Location
    Port Macquarie, NSW
    Posts
    8
    Beginner actually ;-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •