Results 1 to 7 of 7
Like Tree3Likes
  • 1 Post By Dimal
  • 1 Post By Jackster
  • 1 Post By Di_Bartoli

Thread: Bezzera dal 1901 - trying to get it up and running!

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Posts
    3

    Bezzera dal 1901 - trying to get it up and running!

    Hey guys, you will have to forgive my lack of knowledge, I'm new to this and don't know a lot of the lingo!

    I've come across an old bezzera, and wouldn't mind seeing if i can get it up and running as a spare for my partners coffee shop. It's been sitting in storage for a few years so I wasn't sure it would work. Anyway, I plugged it in, connected it to Mains and fired it up. Can hear water flowing into the machine, it lights up and then starts buzzing. None of the taps work, although I got a puff of steam out of 1 of the arms. After about a minute all the lights start flashing and it basically shuts down. Buzzing sound sounds sorta like a pump?
    Pump seems to be spinning ok from what i can see, I disconnected a few of the hoses and bits inside and theyre wet inside so doesn't seem to be too much of a blockage? Any ideas on where to start?
    I'm reasonably handy, can work most stuff out but I'm just not sure where to start!

    - Joel

  2. #2
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    15,943
    G'day Joel...

    Welcome to CoffeeSnobs mate.

    That info you supplied is not a model number but rather the manufacturer.
    Could you possible take a photo of the machine and supply a link to it? Someone here will be able to identify it for you and get you started...

    Mal.
    matth3wh likes this.

  3. #3
    Junior Member
    Join Date
    Dec 2017
    Posts
    3
    [IMG][/IMG]

    hopefully that loads, all sorts of problems with photobucket!

  4. #4
    Senior Member level3ninja's Avatar
    Join Date
    Nov 2013
    Location
    Liverpool area, NSW
    Posts
    763
    Unfortunately not

  5. #5
    Senior Member
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    415
    Forget Photobucket.

    Try tinypic.
    Joelthrum likes this.

  6. #6
    Junior Member
    Join Date
    Dec 2017
    Posts
    3
    Last edited by Javaphile; 19th December 2017 at 07:05 PM. Reason: Fixed link(s)

  7. #7
    Site Sponsor Di_Bartoli's Avatar
    Join Date
    Aug 2006
    Location
    647 Botany Road, Rosebery, NSW 2018
    Posts
    922
    Joel; Check the cont-actor probably has an insect between the metals and is not allowing to close properly to allows the machine to start heating up I seen this happen few times in a commercial machines

    Renzo
    Joelthrum likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •