Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By Yelta

Thread: Steam issues

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Posts
    2

    Steam issues

    Hi
    I have a breville bes920. It's about 2 weeks old. The first week it was great and I was very happy and getting good results with nice creamy thick milk.

    Week 2 and the milk is no longer creamy and frothy. It's just hot. I'm thinking there maybe a problem with the steam wand. The steam only comes out of one or sometimes two of the three holes. I've checked for blockage but there are non. Is it normal that it only comes out of one or two of the holes or should it come out if all three equally?
    Also I can put my hand about an inch away from the steam and it doesn't burn me. The milk is getting hot when I heat it though.

    Would really appreciate some feedback.

  2. #2
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    5,536
    Quote Originally Posted by Sarah2345 View Post
    Hi
    I have a breville bes920. It's about 2 weeks old. The first week it was great and I was very happy and getting good results with nice creamy thick milk.

    Week 2 and the milk is no longer creamy and frothy. It's just hot. I'm thinking there maybe a problem with the steam wand. The steam only comes out of one or sometimes two of the three holes. I've checked for blockage but there are non. Is it normal that it only comes out of one or two of the holes or should it come out if all three equally?
    Also I can put my hand about an inch away from the steam and it doesn't burn me. The milk is getting hot when I heat it though.

    Would really appreciate some feedback.
    It's possible the wand is clogged with milk, have you left the wand immersed in milk as the machine cools? milk can be difficult to steam in Oz during the summer months, dairy cattle are on dry feed, it can affect the milk.

    "Also I can put my hand about an inch away from the steam and it doesn't burn me." take extreme care doing this Sarah, steam burns are nasty and I might add, extremely painful.

  3. #3
    Junior Member
    Join Date
    Jan 2018
    Posts
    2
    No blockage- I’ve taken tip off and can see through the holes. It’s all clear.

    Yes know what youre saying about steam. But my point is I surely shouldn’t be able to do that should I if it was working properly.

  4. #4
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    5,536
    Perhaps time to contact the retailer you bought it from, warranty issue.
    level3ninja likes this.

  5. #5
    Senior Member level3ninja's Avatar
    Join Date
    Nov 2013
    Location
    Casula, NSW
    Posts
    587
    The only other thing I can think to suggest is to use the cleaning tool on the steam tip holes, but I don't know it'll do much. Otherwise you could try a factory reset, then it's warranty territory add Yelta said.

  6. #6
    Senior Member
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    899
    Behmor Brazen - $249 - Free Freight
    This happens on some BES920 machines for some reason, not sure why.

    Try turning the steam tip half a turn anticlockwise and check for steam output. Keep turning it incrementally and observe for any changes. The tip seals to the wand with an o-ring so there's a fair bit of adjustment you can make without it leaking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •