Results 1 to 22 of 22

Thread: Ikon not steaming !!

  1. #1
    Member
    Join Date
    Aug 2007
    Posts
    37

    Ikon not steaming !!

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi,

    I have an Ikon and cant get any steam out of it.

    When I press the steam button, it just blinks continuously, nothing comes out of the steam wand. There is no noise at all from the machine.

    Can anyone here help me ?

    Thanks

  2. #2
    Sleep is overrated Thundergod's Avatar
    Join Date
    Jul 2006
    Location
    Sydney
    Posts
    10,496

    Re: Ikon not steaming !!

    When did it last work?

    When did you last descale it?

  3. #3
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    I just came back from a 1 month holiday, worked fine for a week and now it decides it wont do it.

    I descale it every 6 months or so, the water here is fine (Darwin) and I filter it too.

    Actually, Ive just managed to get it to work, but the steam wasnt even anywhere near hot. Now it doesnt work again.

  4. #4
    Senior Member
    Join Date
    Dec 2009
    Posts
    104

    Re: Ikon not steaming !!

    Do you have the little steam wand tool, take off the tip and see if the tip is blocked?

  5. #5
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    Yeah ive cleaned the wand tip, its not that.

    Its not even going into steam mode, maybe its something electrical?

    Usually you hear some noises after you press the steam button, now its just silent and I know nothing is going to come out

  6. #6
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    I opened it up and took some photos if anyone is interested :



    This looks a bit dodgy :



    Is that the steam thermostat in the top right with the crap around it?

    It can still pour an espresso shot ok, so Im guessing the boiler is ok.

    Funny thing is, occasionally it will steam ok.

    Anyway, Ill think Ill send it to a Breville service centre, just hope its not a complete write off.

  7. #7
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 787D727575130 link=1263640243/5#5 date=1263995238
    I opened it up and took some photos if anyone is interested :



    This looks a bit dodgy :



    Is that the steam thermostat in the top right with the crap around it?

    It can still pour an espresso shot ok, so Im guessing the boiler is ok.

    Funny thing is, occasionally it will steam ok.

    Anyway, Ill think Ill send it to a Breville service centre, just hope its not a complete write off.
    Where are you located...

  8. #8
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    Im in Darwin, and there are no Breville service agents here.



  9. #9
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 44414E49492F0 link=1263640243/7#7 date=1264022888
    Im in Darwin, and there are no Breville service agents here.

    A decent Appliance centre that looks after other coffee brands MAY be an option... But only if ya trust them..

    How old and what does Breville say ?

    Now if ya were just down the road.... Or had a deal with the post man...

  10. #10
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    Its about 2.5 year old.

    Breville couldnt help, told me I could post it to a service centre but its not under warranty so it would cost a bit.

    I dont really want to spend ~$70 on postage to find out its a write off.

    Any idea on what needs replacing and how much it would cost ?

    Whats the worst case scenario ? Replace boiler, thermostat, seals etc ?

    Thanks for your help so far.

  11. #11
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 6366696E6E080 link=1263640243/9#9 date=1264029211
    Its about 2.5 year old.

    Breville couldnt help, told me I could post it to a service centre but its not under warranty so it would cost a bit.

    I dont really want to spend ~$70 on postage to find out its a write off.

    Any idea on what needs replacing and how much it would cost ?

    Whats the worst case scenario ? Replace boiler, thermostat, seals etc ?

    Thanks for your help so far. *
    Sorry... As I stated in another post... *With out first hand access and some testing... *

    It could be a simple thermal cut-out or much worse.. *No pump sound in steam mode could be teh controller or a separate steam thermal fuse that also disables *the pump.

    Without looking and taking measurements... * Who knows.

    Witch model Ikon exactly ?

    Could just be the Steem control know / switch or even a blocked Steam wand or steam path..

    If ya have the usual hot water for coffee then it shpould be in the steam side...

    What sort of water do you use in it up there... I mean NT water will even rot poly water tanks over a few months ;D :D ;)

  12. #12
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    BES400, is there any other model ?/\/

    No no no, the water in Darwin is clean ;D

    Even still,I have always used filtered water from a Brita jug.

    I have a theory that it packed up because I didnt use it for 1 month while I was on holiday.

  13. #13
    Senior Member
    Join Date
    Jan 2008
    Location
    Brisbane, Queensland, Australia, Australia
    Posts
    1,756

    Re: Ikon not steaming !!

    Quote Originally Posted by 41444B4C4C2A0 link=1263640243/11#11 date=1264045254
    Even still,I have always used filtered water from a Brita jug.
    I had a laugh, have a search for Brita Jugs and see what comes up........they dont work for coffee, they will NOT remove scale, on a side note, how is sunny darwin, i lived there for about 5 years, loved it! ;D

  14. #14
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 60656A6D6D0B0 link=1263640243/11#11 date=1264045254
    BES400, is there any other model ?/\/r

    No no no, the water in Darwin is clean *;D

    Even still,I have always used filtered water from a Brita jug.

    I have a theory that it packed up because I didnt use it for 1 month while I was on holiday.
    You also said it worked and then it did not ??

    1: Blockage ???

    2: Steam thermistor (if it has one)

    3: Steam switch

    Does it give hot water for coffee OK ?



  15. #15
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    Hot water for shots is fine & through the steam wand.

    Ive managed to jag the steam to work about 3-4 times in the past week. When it does work, it works fine, no loss of pressure or watery steam - works like it should. No sign of a blockage.

    But every other time I press the steam button, it just flashes and nothing comes out the steam wand - the machine is just silent.

    Oh, its wet season now in Darwin so you get those amazing electrical storms rolling in the afternoon. Great place to live !!!

  16. #16
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 2D28272020460 link=1263640243/14#14 date=1264060534
    Hot water for shots is fine & through the steam wand.

    Ive managed to jag the steam to work about 3-4 times in the past week. When it does work, it works fine, no loss of pressure or watery steam - works like it should. No sign of a blockage.

    But every other time I press the steam button, it just flashes and nothing comes out the steam wand - the machine is just silent.

    Oh, its wet season now in Darwin so you get those amazing electrical storms rolling in the afternoon. Great place to live !!!
    Check the steam knob and make sure it is not loose ...

    Page 16 of the manual.. Steam Control Dial has not been turned towards ‘MAX’ position

    If like the SB it also makes a switch and that could be faulty / touchy...

  17. #17
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    I crudely measured the brew temp from the group head at 62 degrees.

    Too low or not ?

  18. #18
    Senior Member Koffee_Kosmo's Avatar
    Join Date
    Apr 2008
    Location
    Brisbane
    Posts
    5,113

    Re: Ikon not steaming !!

    Quote Originally Posted by 2C29262121470 link=1263640243/16#16 date=1264218641
    I crudely measured the brew temp from the group head at 62 degrees.

    Too low or not ?
    Crudely measured is fraught with danger
    It should be in the range of 92 - 96 deg Celsius

    KK

  19. #19
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    It seems to work but only when the machine is turned on from cold.

    Just pulled a shot, tried the steam and to my surprise it was fine.

    I finished steaming my milk, turned off the steam and drank my latte.

    Now, it doesnt work again. Will try this again later once the machine cools down to see if this is a pattern.

  20. #20
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 787D727575130 link=1263640243/18#18 date=1264230434
    It seems to work but only when the machine is turned on from cold.

    Just pulled a shot, tried the steam and to my surprise it was fine.

    I finished steaming my milk, turned off the steam and drank my latte.

    Now, it doesnt work again. Will try this again later once the machine cools down to see if this is a pattern.
    Sounds like a thermal cut-out kicking in.. *And will only reset one turned off and cooled down.

    Have not yet seen / pulled one apart OR been able to find any detailed electrical drawings...

    So only conjecture on my part...

    Will see if I can get some info from a contact... Monday at best... More than likely Wednesday if they can delver....

    AM

  21. #21
    Member
    Join Date
    Aug 2007
    Posts
    37

    Re: Ikon not steaming !!

    Thanks, really appreciate your help ;)

  22. #22
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon not steaming !!

    Quote Originally Posted by 27222D2A2A4C0 link=1263640243/20#20 date=1264244165
    Thanks, really appreciate your help *;)
    Can only do so much when the units are not managed by a sponsor and have not direct personal experience with them....

    FIX was a sponsor at one time and I think he still posts on occasion.. Ya could try a PM to him.. *Might be worth a go; as he is a service agent / repair person ??? and may provide some info..

    Plus ya in the NT and I know how frustrating it is when ya know that if ya were any where else it would be a done deal..

    AM




Similar Threads

  1. Ikon Users !! need help 4 Broken Ikon (no steam?)
    By maheel in forum Brewing Equipment - Entry level (sub $500)
    Replies: 17
    Last Post: 13th October 2010, 09:38 AM
  2. Breville IKON - steaming cappuccino for one serve?
    By benjamind in forum Brewing Equipment - Entry level (sub $500)
    Replies: 3
    Last Post: 4th May 2008, 04:57 PM
  3. Steaming UHT
    By tomasia_bella in forum Milk Froth and Bubbles
    Replies: 9
    Last Post: 17th March 2007, 02:26 AM
  4. Steaming Soy
    By lucinda in forum Milk Froth and Bubbles
    Replies: 26
    Last Post: 9th March 2007, 05:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •