Results 1 to 18 of 18

Thread: Ikon Users !! need help 4 Broken Ikon (no steam?)

  1. #1
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Ikon Users !! need help 4 Broken Ikon (no steam?)

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    need some help

    I have a Ikon i got for nothing and although it heats up it does not make steam.

    it turns on heats up pump runs and fills etc seems hot and looks like it will make a shot but when i press the steam button NO steam (it does not heat up extra hot for steaming)

    steam button seems to do something if i hold it in a long time, goes into some sort of program / clean mode?

    no manual (still looking online) but assume you just press "steam" and wait but nothing happens

    i have the top off it and it all looks OK but no steam??
    any thoughts?

    Maheel


  2. #2
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Electronic :-)

    Would need to have in my shed and ability to measure / play *:D

    Ya know where I am...

    Cubby is a drop off point if I am not at home...

    Sundays are usually good but have a Function this Sunday and will be attempting to provide 105 guests with coffee *:o

    May have a little time on Saturday... As the weather is putting stop to a few other things...

    AM



  3. #3
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    yeah thinking that AM

    might have a bit more of a play of the basics, no rush will give you a shout if no joy

    just thought if it can be coaxed back to life I can pass it on to someone in need etc

    at worst a few more parts in the "parts box" to pay it forward :)


  4. #4
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 6468616C6C65090 link=1286525317/2#2 date=1286527103
    yeah thinking that AM

    might have a bit more of a play of the basics, no rush will give you a shout if no joy

    just thought if it can be coaxed back to life I can pass it on to someone in need etc

    at worst a few more parts in the "parts box" to pay it forward *:)
    Any time.. *Problem is if a driver or timing cct is dead or not getting a signal... *Who knows what Easter egg the programmer has embedded for when the steam button is held down.

    We had a habit of embedding Quotes and paragraphs of Tolkin in some of our code that we developed for some medical analysers many years ago.

    Then about 5 years later I was just looking with a hex editor one day, as some stuff was performing same type of function... *Presto.. Not only some of our code and *Quotes but a response or two...

    BOT.

    It could also be a sensor that is causing the system to not respond or another switch that is active and thus the steam and Unknown is then putting the system into the clean mode you mention ? *Just a thought..

    Do you have ausers manual ? Maybe stuck in some other mode and thus the reason some one put it on the footpath *;D :D ;)

    No Steam = "Steam Control Dial has not been turned towards ‘MAX’ position"

    PS. Now for some BF1942 ;D




  5. #5
    Junior Member
    Join Date
    Aug 2010
    Posts
    20

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    i had this problem with my refurbished breville unit...

    i sent it back to breville and even their technicians couldnt fix it so they gave me a new machine...

  6. #6
    Senior Member
    Join Date
    Sep 2010
    Location
    Sydney, Australia, Australia
    Posts
    218

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 4F60696B7C436F606F696B636B607A0E0 link=1286525317/3#3 date=1286527667
    No Steam = "Steam Control Dial has not been turned towards ‘MAX’ position"

    *
    You took the words out of my head...

    Also, to the OP, you need to "prime" your steam wand beforehand because I had the same problem when I first got mine.

    i.e. DONT turn on the steam button, turn your dial to MAX and let water flow until nothing comes out fo the steam wand.
    THEN turn on steam button and turn up dial to MAX to check steam wand is working.

    Otherwise ask Breville *::)

    P.S. FYI the dial is on the RIGHT HAND SIDE when facing the machine.

  7. #7
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    this machine does not have a steam dial....



    just a button....

    anyway i picked it up free, was told it had the no steam issue. i thought i would pull it apart to see if it was fixable...

    thought a basic issue might be.
    1. button stuffed / moved (dont think this is the issue)
    2. heating element ( dont think so as only 1 and gets heat to brew)
    3. loose something like micro switch etc (dont think so)
    4. loose wire. still need to check

    more serious issues.
    1. stuffed control board....
    2. its stuffed

    if not fixable, it has some parts that someone will want in the future...
    pump, water tank, ghandle.... ete etc

    right now its under the stairs.... got told "dont leave that POS there for the weekend..." :) I had a laugh *but i will drag it back out at a later date

    Quote Originally Posted by 6E6B6E6F676A020 link=1286525317/5#5 date=1286769965
    Otherwise ask Breville *::)
    hahahhhaaa hhaa..............

  8. #8
    Senior Member
    Join Date
    Sep 2010
    Location
    Sydney, Australia, Australia
    Posts
    218

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 3E323B36363F530 link=1286525317/6#6 date=1286771172
    this machine does not have a steam dial....
    See below:



  9. #9
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    yeah but it does not have any wires running to it i mean, no micro switches etc.

    but i see what you mean now, and i tried bleeding off some water etc then pressing buttons. your idea is a good one and i will try it again.

    but its not boiling for steam

  10. #10
    Senior Member
    Join Date
    Sep 2010
    Location
    Sydney, Australia, Australia
    Posts
    218

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 717D747979701C0 link=1286525317/8#8 date=1286772046
    yeah but it does not have any wires running to it i mean, no micro switches etc.

    but i see what you mean now, and i tried bleeding off some water etc then pressing buttons. your idea is a good one and i will try it again.

    but its not boiling for steam
    BTW, the bleeding on an Ikon takes about 1-3 mins for priming (all buttons on, steam button not blinking) and 30 secs-1min for steam (after pressing steam button, steam button blinking)

  11. #11
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    thanks Lilmeh

    will give it a try i was a bit lost in trying to understand what you meant

    although not confirmed the original owner told me steam had stopped working so i am assuming its got a issue.

    by steam dial i was thinking like the 6910, where the steam switch is included in the dial, or the other models where you "turn" that dial lookig thing on the front to steam.

    Cheers

  12. #12
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 39353C313138540 link=1286525317/10#10 date=1286773296
    thanks Lilmeh

    will give it a try i was a bit lost in trying to understand what you meant

    although not confirmed the original owner told me steam had stopped working so i am assuming its got a issue.

    by steam dial i was thinking like the 6910, where the steam switch is included in the dial, or the other models where you "turn" that dial lookig thing on the front to steam.

    Cheers
    DO not give up...

    But when you do - I want first dibs at teh next stage of resurrection ;D

  13. #13
    Senior Member
    Join Date
    Sep 2010
    Location
    Sydney, Australia, Australia
    Posts
    218

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    On the Ikon, (after priming), you have to press the steam button so that it blinks and then turn the dial to start heating. Hope this clarifies it up. :)

    Good luck!

  14. #14
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    so i went and got it from under the stairs....

    like before gets hot for shots
    once you press the steam
    the steam light blinks but no heat.... wand open or closed etc

    popped it open and pushed, pulled, tapped and probed but no help

    back it goes for now

    AM if your headed to Hawthorne area and want to take it home PM me



  15. #15
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 7478717C7C75190 link=1286525317/13#13 date=1286776461
    so i went and got it from under the stairs....

    like before gets hot for shots
    once you press the steam
    the steam light blinks but no heat.... wand open or closed etc

    popped it open and pushed, pulled, tapped and probed but no help

    back it goes for now

    AM if your headed to Hawthorne area and want to take it home PM me

    Could be over that way mid morning etc.. OR about lunchtime... Have a small job at Greenslopes..

    I will flick ya a PM.. Once I know more.

  16. #16
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Just got inside it and looks like a typical popped CAP. *35V 220uF was blown and appears to be in a timing cct.. *Who knows as it is all drived by a special ic. *

    Reasonable well made system and very clean, but what a small boiler *;D

    Have just soldered in a new cap and will test it some time soon...

    Update. Still dead as to steam...

    The transistors (configured as Darlington) are OK, but I did notice a spill has happened on teh switch panel and dried scum over teh connector.

    Coils and relay all ok.

    Thus it could have taken out an input on teh main IC.

    Such is life... Bits for a pay it forward maybe ?


  17. #17
    Senior Member
    Join Date
    Jun 2008
    Posts
    1,520

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    thats a shame AM as it did seem to be in ok condition

    yeah keep it for parts, or you can return to me at a later date if you dont have space to store.

    if it gets pulled apart keep me the brass bits like the steam tap, pipe ends etc if not required as i might want them for my home brew builds.
    I was looking at that brass steam tap....

  18. #18
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Ikon Users !! need help 4 Broken Ikon (no steam?)

    Quote Originally Posted by 434F464B4B422E0 link=1286525317/16#16 date=1286922869
    thats a shame AM as it did seem to be in ok condition

    yeah keep it for parts, or you can return to me at a later date if you dont have space to store.

    if it gets pulled apart keep me the brass bits like the steam tap, pipe ends *etc if not required as i might want them for my home brew builds.
    I was looking at that brass steam tap....
    Plenty of space and I have other bits that you may be able to use once you get sorted and settled..

    The hardware looks OK.. With no electronics diag and often hard encoded controlled chips (not available as a part ) it is never a 2min fix and often not possible full stop.

    Still have a trick or two up my sleeve... But not a high priority at this stage ;)



Similar Threads

  1. !!!GONE!!! - Broken Breville Ikon - give away for parts
    By mrpoppy in forum Paid Forward - Taken
    Replies: 1
    Last Post: 20th July 2012, 11:59 AM
  2. IKON steam tip broken off due to overtightening
    By scottishrambo in forum Brewing Equipment - Entry level (sub $500)
    Replies: 7
    Last Post: 1st July 2011, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •