Results 1 to 2 of 2

Thread: Breville 800es, lights on but not working

  1. #1
    Member
    Join Date
    Jun 2011
    Posts
    34

    Breville 800es, lights on but not working

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi, Im new here and not Im not sure this is the right place to put this post. To start of with, I have a Breville 800es which lights on but does not appear to function. Ive look at various forum for a solution without success. Ive contacted Breville Australia and was told that it would likely cost me at least a few $100s to check and fixed as it is apparently out of warranty. I would probably upgrade if there isnt a way to bring it back to life with a simple tip here and there. Thanks.

  2. #2
    Member
    Join Date
    Jun 2011
    Posts
    34

    Re: Breville 800es, lights on but not working

    I read somewhere that if the red light is flashing for heat that the machine might be indicating that no water is being drawn into the thermoblock. If that is the case, could it mean the pump is shot?
    Please correct me if im wrong.



Similar Threads

  1. Breville 800ES: pump stops working after a few secs of providing coffee
    By jslikker in forum Brewing Equipment - Entry level (sub $500)
    Replies: 6
    Last Post: 29th June 2016, 09:17 AM
  2. Will an Breville Ikon pf work on a Breville 800ES??
    By jkwa in forum Brewing Equipment - Entry level (sub $500)
    Replies: 2
    Last Post: 18th February 2012, 01:45 PM
  3. Replies: 7
    Last Post: 11th June 2009, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •