Results 1 to 7 of 7

Thread: EM5600 blocking up

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Posts
    2

    EM5600 blocking up

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi there, havent been on here before but Im driven to desparation... our Sunbeam EM5600 has been going fine for a few years - replaced the brew head seal last year and again a week or so ago, but since putting it back together, it will only pour a few mLs of coffee before hot water starts to escape out the side, between seal and portafilter. Its as though the seal isnt working or something. Ive checked the seal several times but cant figure out anything different to how I screwed it in before. Any suggestions?

  2. #2
    Senior Member specialpants's Avatar
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    310

    Re: EM5600 blocking up

    have you tried it without having coffee in the basket?

  3. #3
    Junior Member
    Join Date
    Aug 2011
    Posts
    2

    Re: EM5600 blocking up

    yes Ive tried it without coffee, does the same thing - so nothing to do with coffee tamp/grind.

  4. #4
    Senior Member specialpants's Avatar
    Join Date
    Dec 2010
    Location
    Sydney
    Posts
    310

    Re: EM5600 blocking up

    It could be one of many reasons: Pick the one that suits you the most:

    It could be that youre not locking it in far enough (where is it at the moment? 6 oclock, 5 oclock etc)

    The plastic collar is worn - I had to replace mine because it actually cracked under pressure.

    Basket is clogged. Are you using dual wall baskets?
    Theres a chance that the baskets are clogged and building up excessive pressure causing it to leak everywhere.

    If you have access to a different basket that doesnt get used much (ie single cup basket), try loading it without any coffee and see if it happens.

  5. #5
    Junior Member
    Join Date
    Aug 2011
    Posts
    1

    Re: EM5600 blocking up

    Bought a brand new EM5600 and have only had a few coffees without the head spurting out under pressure. Sunbeam said the blend was too fine. So have spent $30 on 3 different blends and bang it explodes out each time. Im bloody sick of it. Its only 2 weeks old. Suggestions please Mr Sunbeam :(

  6. #6
    Senior Member fatboy_1999's Avatar
    Join Date
    Jul 2004
    Location
    Melbourne
    Posts
    2,118

    Re: EM5600 blocking up

    Its more likely to be that the GRIND is too fine.
    Little or nothing to do with the blend.
    If you are grinding it, grind coarser.
    If you are not grinding it, you are fighting a losing battle, but perhaps you can put less coffee in the basket and see if that helps.
    You really need to be grinding it yourself to have any control though.

    Brett.

  7. #7
    Junior Member
    Join Date
    Sep 2010
    Posts
    1

    Re: EM5600 blocking up

    I have similar problems with my EM5600. I bought in Sept 2010. Put up with problem from day 1 {tried many suggestions - grind, cleaning etc}. Sometimes could make really good coffee, then not. A month or so ago the pump would not turn off by its switch {had to turn off at power point}. So exchanged for new machine {Sunbeam were quite good about it}. New machine works great for 2 weeks and now back to pressure escaping once again. Ready to throw it in the bin. I am a novice but have played with grind, thought about humidity {barista suggestion}, I have flushed machine after each use from first purchase. I have tried less coffee in the basket. I reckon there is a production fault with the seal where you attach the basket. if only it did not have this problem it would otherwise be a great machine considering the price. Any other suggestions from readers? If I upgrade what machine would readers suggest to consider? :(



Similar Threads

  1. Compak K3T blocking up
    By David8 in forum Grinders
    Replies: 6
    Last Post: 11th March 2012, 03:01 PM
  2. EM2300 gushing, and/or blocking up!
    By jameslol in forum Brewing Equipment - Entry level (sub $500)
    Replies: 4
    Last Post: 7th September 2011, 05:14 PM
  3. EM0480 Blocking
    By aussieflicker in forum Grinders
    Replies: 3
    Last Post: 22nd September 2008, 08:20 PM
  4. EM5600 Constantly having problems with it blocking
    By Mdhatter in forum Brewing Equipment - Entry level (sub $500)
    Replies: 3
    Last Post: 22nd June 2008, 02:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •