Results 1 to 3 of 3

Thread: Sunbeam EM5900 Arista - descaling problem

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Posts
    1

    Sunbeam EM5900 Arista - descaling problem

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    I have a Sunbeam EM5900 Arista espresso machine which, I have just descaled it for the first time. Once it was all put back together I tried to attached the group handle and I cant, it is like the washer doesnt fit back properly... Has anyone else had this problem and if so how did you fix it...

    Thanks in advance!

  2. #2
    Senior Member
    Join Date
    Sep 2011
    Posts
    395

    Re: Sunbeam EM5900 Arista - descaling problem

    Errr, why did you take the machine apart to descale? Usually a descale for thermoblock machines just means running the solution through the system...

  3. #3
    Senior Member
    Join Date
    Aug 2011
    Location
    Launceston
    Posts
    130

    Re: Sunbeam EM5900 Arista - descaling problem

    Sounds like you removed the shower screen and seal and may not have got it quite back together the same way.* You might need to wander into a shop that sells this machine and have a squizz.



Similar Threads

  1. Expobar minore and descaling, problem????
    By coffeechris in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 60
    Last Post: 14th November 2014, 05:56 PM
  2. Gaggia Platinum Vogue - Problem clearing descaling indicator
    By knetix in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 1
    Last Post: 31st July 2009, 05:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •