Results 1 to 6 of 6

Thread: Breville Ikon BES400 switch assembly

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    19

    Breville Ikon BES400 switch assembly

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi Guys,

    My Aunty has a Breville Ikon BES400 and the switch for steam is not working anymore.

    Anyone know whether you can get a replacement or it is not worth it?

    Thanks!

  2. #2
    Member
    Join Date
    Jul 2009
    Location
    Sydney, NSW
    Posts
    49
    Where are you located?

    I've got an Ikon, I think the pump is gone on it. But steam is defo still working. If you want it you can have it, collect from Inner West Sydney?

    cheers

  3. #3
    Junior Member
    Join Date
    Dec 2009
    Posts
    19
    Quote Originally Posted by eggs View Post
    Where are you located?

    I've got an Ikon, I think the pump is gone on it. But steam is defo still working. If you want it you can have it, collect from Inner West Sydney?

    cheers
    You LEGEND!

    Only thing is, I'm in Tassie, and they are in Hong Kong! I'll see what she says then let you know.

    Thanks again!

  4. #4
    Junior Member
    Join Date
    Mar 2014
    Posts
    1

    Brevelle BES 400 no steam

    I've had same problem twice
    Once Breville fixed under duress as just out of warranty and no parts

    Last week same problem.
    I tracked problem down to the big yellow 1.5uf 280v capacitor on the power supply board.
    It wasn't passing enough current
    when plugged in the 24volts and 5 volts were OK
    when pressing the On button the Heater relay calls and on light flashes the 24 volt drops to 11volts and the 5v to 4v
    Once up to heat the 24 voltage rises to 14v
    when you press the steam button there the 14vis no enough to call the heater relay and the seam light just keeps flashing.
    I replaced the faulty capacitor

    Now enjoying frothy cuppaocno
    agan

  5. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    171
    Quote Originally Posted by Mike787 View Post
    I've had same problem twice

    Last week same problem.

    I replaced the faulty capacitor

    Now enjoying frothy cuppaocno
    agan
    Hey mate, great to hear I'm not the only one who has had this problem more than once!
    Where can I get one of them capacitors??

  6. #6
    Senior Member
    Join Date
    Feb 2008
    Posts
    171
    continued after a 20 month break...
    http://coffeesnobs.com.au/brewing-eq...tml#post569086



Similar Threads

  1. Breville Ikon (BES400) Summary
    By Astranomical in forum Brewing Equipment - Entry level (sub $500)
    Replies: 58
    Last Post: 19th November 2011, 04:52 PM
  2. !!SOLD!!: Breville Ikon (BES400)
    By matt84 in forum SOLD
    Replies: 1
    Last Post: 20th February 2011, 02:58 PM
  3. Blind Filter for Breville Ikon (BES400) ?
    By ahxiongko in forum Brewing Equipment - Entry level (sub $500)
    Replies: 4
    Last Post: 21st April 2009, 06:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •