Results 1 to 10 of 10

Thread: Help with Faema Family

  1. #1
    Junior Member
    Join Date
    Jul 2014
    Posts
    7

    Help with Faema Family

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello all,

    I am brand new to coffee snobs and the world of home espresso in general. After living in NSW for nearly a year, then subsequently in NZ for 8 months I brought my love for a good shot back to Canada.

    I just purchased a Faema Family for, what I feel, was a steal at $50. It was that or the Starbucks Barista at $150. Something about the Faema sang to me.

    After bringing it home I did some research and found this site. Extremely informative and, from what I gather, I feel I've picked up a pretty decent home brew unit.

    My concern is that I may be missing an electronic piece on the top of the boiler. After looking at the pictures Sparky had posted and taking my machine apart, it appears that I may missing the High Temperature Cut Out Thermostat. I have pictures of my machine and was hoping for some confirmation. I am new and cannot post attachments. As well, after taking the machine apart, I see now loose connectors that would indicate the Thermostat had been removed. I'm a little confused and worried that this could cause major issues down the road.

    As well, the tip of the steam wand seems to be absolutely plugged, any advice on how to get this back to operational condition?

    Also, any general advice, warnings, tips, mods, that I should be considering with the machine would be great.

    As far as I know its the older version with the brass boiler.

    Thanks to anyone who can be of assistance. I really appreciate it and look forward to being a part of the community.

    Cheers

  2. #2
    Senior Member
    Join Date
    Jan 2014
    Location
    Sweden/Germany
    Posts
    140
    maybe that helps you
    http://coffeesnobs.com.au/general-co...-pictures.html
    picture are saying more thern 1000 words.

  3. #3
    Junior Member
    Join Date
    Jul 2014
    Posts
    7
    Thanks Rolf,

    Looked into that, I believe those instructions are for an older version of the site. I've read further that, from what I understand, I need to post 5 posts before I have the ability to post pictures. Hopefully this resolves things and I can put picture of my unit up soon.

    Thanks for the reply!

  4. #4
    TOK
    TOK is offline
    Senior Member
    Join Date
    Apr 2013
    Posts
    697
    Welcome to CS ajlibby.

    you sound perfectly genuine in which case I suggest you do a little tour round the site and place some judicious posts in reply to whatever is going on, and get your 5 posts up so that you can post your photo here.

    Regardless, I hope the following will be of some help.

    The Faema Family is a very old model and I can remember selling them in the *early* 80's. Honest ! And yes, it was a very decent domestic use unit particularly for its time.

    I havent checked and I dont know how hard it is going to be to track down a schematic diagram for something that old, but realistically all you need to do is find out what was on top of the boiler...order it, fit and and plug it in.....or so it sounds from your post.....it will be either of the steam thermostat OR the overtemperature (safety) thermostat.

    I dont know anything about them having anything other than a brass boiler.

    In terms of you causing major issues...well you will, if you attempt to use it in its incomplete form without whatever is missing and with unconnected possibly uninsulated wiring. Afraid it isnt a goer as it is. Work out what's missing, the correct way to wire it up, and go from there.

    Warning: NEVER work on a coffee machine if its plugged in, so leave the plug out of the wall until it's ready to start up to test the effectiveness of your repairs. Does your home have an "earth leakage circuit" and if not can you buy one of those portable power boards with resettable overload on the circuit breaker? They're a good idea...

    Blocked steam tips are relatively easy. Unscrew the tip from the end of the pipe and clean it out, screw it back on. If the seal is buggered or there isnt one, or you lose it, its ok to use some plumbers tape. When the machine is operational you can blow the circuit out with steam, and that will indicate if there is any blackage further up the line.

    Another tip: Please dont try to "mod" anything. With a machine this old it will be good enough to get the thing running properly and learn how to use it. And even then you will be using it for an extended period to understand the best modus operandi to get great coffee....which it is perfectly capable of giving....if you learn to use it properly. The model was way ahead of its time and is indicative of what a powerful force in the coffee machine industry that Faema used to be in those days....Never mind what Sparky or others have done.....and in terms of that, are you looking for a coffee machine or a project? iF you are looking for a coffee machine, leave it alone and enjoy.

    I had two of these out back that I could have used to photograph for you and indicate parts and wiring, but unfortunately some of my people had a big clean out and they disappeared....so i am afraid I cant offer any help there...

    Good luck.

  5. #5
    Junior Member
    Join Date
    Jul 2014
    Posts
    7
    Cheers for the info TOK,

    Just takes a little time to rack up the posts. Found a little time this evening after work so have added my two cents to a few topics. Hopefully I'll be able to post attachments soon enough.

    On inspection, I'm very confident that it is the over-temperature thermostat with the reset. Hopefully will be able to track one down and get it installed. I feel pretty confident with mechanical issues, but the electronic side of things scare me a bit. Not the best at wiring I hate to admit.

    Also would like to replace any seals and gaskets that may need it.

    As far as mods go, only thing I was thinking of was changing out the shower screen. Perhaps a bottomless porta filter at some point, but have more important things to purchase before that (grinder!)

    Hopefully pictures will be up soon.

  6. #6
    Junior Member
    Join Date
    Jul 2014
    Posts
    7
    Here are a few photos of the naked machine. The pen is pointing to where the missing? thermostat is. As well, not pictured is the drain hose from the three way valve. It appears one end goes into the drip tray and there is a loose end that does not terminate and just hangs out in the machine. Not too sure the purpose of this. Anyway, any help, suggestions, comments, would be greatly appreciated. Thanks all!
    .

    IMG_20140630_230127.jpgIMG_20140630_230109.jpgIMG_20140630_230139.jpg

  7. #7
    GT2
    GT2 is offline
    Junior Member
    Join Date
    May 2015
    Posts
    4
    Perhaps someone on this thread can help me. After 26 years of trouble free service, the pump my Faema Family has expired. It was a good opportunity to disassemble the machine, clean up a little corrosion and touch up the paint on the case. I ordered a new pump that is due to arrive this week. My problem is that I paid insufficient attention during disassembly. There is a rubber tube that is attached to the 3-way valve. It attaches to a T-fitting. One of the hoses then drains to the drip pan. My question is where does the other hose go? It does not appear to have been previously attached to any fitting. Any help would be appreciated.

  8. #8
    Senior Member
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    1,104
    That hose doesn't go anywhere, it's just a spare to fill the extra outlet on the t piece. Not sure why they built it like that.

    Whilst you're in the machine, would you be able to take a photo of the steam switch and the connections behind it?
    I've rebuilt a family and everything works except when I hit the steam switch it trips the breaker.
    I'm pretty sure it's not thermostats or anything but it's definitely something I've done wrong with wiring.

  9. #9
    GT2
    GT2 is offline
    Junior Member
    Join Date
    May 2015
    Posts
    4
    I am traveling, but when I get home this weekend I will photograph and post the steam switch.

    with regard to the extra hose, where did the manufacture place it so it would not introduce moisture into the electrical area?

    thanks

  10. #10
    GT2
    GT2 is offline
    Junior Member
    Join Date
    May 2015
    Posts
    4
    Quote Originally Posted by noidle22 View Post
    That hose doesn't go anywhere, it's just a spare to fill the extra outlet on the t piece. Not sure why they built it like that.

    Whilst you're in the machine, would you be able to take a photo of the steam switch and the connections behind it?
    I've rebuilt a family and everything works except when I hit the steam switch it trips the breaker.
    I'm pretty sure it's not thermostats or anything but it's definitely something I've done wrong with wiring.
    I have noticed that on mine the Hot Water button (second from the bottom) utilizes only 3 of the 4 electrical lugs. Apparently I am too new a user to be trusted posting attachments. I will see if I can PM you the picture..



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •