Results 1 to 3 of 3

Thread: Help! Water coming out unevenly on used Gaggia Classic

  1. #1
    Junior Member
    Join Date
    Jul 2014
    Posts
    1

    Help! Water coming out unevenly on used Gaggia Classic

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi there.

    I recently picked up a used Gaggia Classic, 4-5 years old.

    Here's a vid of what's happening: Video - TinyPic - Free Image Hosting, Photo Sharing & Video Hosting


    Here's a vid (not by me) of what it should look like: https://www.youtube.com/watch?v=egeuQThBcG8


    I pulled the thing apart when I got it home and gave it a thorough clean, inside and out.
    I replaced the group head seal with a new one and soaked all the metal parts in Cafetto

    Espresso Clean.


    I descaled it this morning.


    Does anyone know why this is happening/what I can try to fix it?


    Thank you!!

  2. #2
    Senior Member
    Join Date
    May 2014
    Posts
    545
    pmcca,
    Hello and welcome,I've just looked at your video....what's the problem,it seems be be functioning as a new one would,at least by my observation?
    Are you suggesting that once the group handle in fitted and a brew is activated it behaves differently?
    I have four of these and all have been stripped and rebuilt,they work just as your video shows...perfectly!
    More information please!
    Cheers,
    Mick.
    Just revisited your "you tube" thingy,perhaps a clean up of the shower screen (as you have done) and a check to ensure the four holes in the group head disc are clear (as you have done as well).
    Cheers.
    Mick
    Last edited by mulquemi; 20th April 2015 at 10:56 AM.

  3. #3
    Member
    Join Date
    Mar 2015
    Posts
    35
    My Gaggia pours exactly the same as yours does mate. Nothing wrong with it



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •