Results 1 to 2 of 2

Thread: Fixing an EM5900

  1. #1
    Junior Member
    Join Date
    May 2015
    Posts
    8

    Fixing an EM5900

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hey guys, I just found an EM5900 with all accessories in front of someone's house (put out for kerbside pickup). Grabbed it and brought it home and it seems to go well! That is except the Steam/Hot Water function doesn't work at all. The manual says it is supposed to turn the Steam light green when it is ready, then to turn the knob on the side. Mine just sits there with a white light and no steam comes out. I can hear some clicking coming from the back of the machine. It's not a blockage because water/steam does come out but only when I press the coffee button (instead of coming out the group handle).

    Basically I want to know two things: 1) is it worth asking Sunbeam to fix this (it WAS a $450 machine) and 2) is it worth fixing it to replace my EM3600? I really like the thicker, heavier group handle but from what I can see all Sunbeams are really the same eg thermoblock design, 15bar pump etc.

    Thoughts?

  2. #2
    Rbn
    Join Date
    Nov 2010
    Location
    Southland NZ
    Posts
    443
    I guess no one really knows! If it was me, because I like to know how things work, I would tinker with it.

    I have an EM6910, used, from my son, he bought new one, his old one only needed a new steam thermobloc, got used, but new, from a repair agent, all fixed for $40.00.

    And we have an EM4800C in our camper van, gives good service.
    Last edited by rawill; 25th June 2015 at 10:08 AM.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •