Results 1 to 6 of 6

Thread: Issue with Giotto Evo

  1. #1
    Member
    Join Date
    Jan 2011
    Posts
    38

    Issue with Giotto Evo

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all,

    Experiencing a new problem with my Evo over the weekend, hoping to find someone here who has had the same issue on the Evo or HX equivalent.

    When the lever is pulled up to start flow from the group head (no coffee/empty portafilter), for the first 5-10 seconds I am only getting a little splutter and some steam, then the flow starts.* :-?

    Not good.

    If I stop it, and then start again straight away, no such problem. If it is left for a few mins however, we get the same issue.

    Im not sure if its my imagination, but more water than usual seems to be coming out of the drain from the 3 way solenoid. It usually spurts after a shot is stopped, then drip for a few seconds, then drip very slowly for 30 seconds and stop. Now it spurts, drips, slowly drips, then a little water runs out, then slow drip, then very little dipping, then suddenly more water, and so on for a few minutes at least. Hope that makes sense.* :-/

    Is it the solenoid leaking, some worn seal? Could all be my imagination, and there is some other completely reasonable explanation.

    Machine is still covered by warranty, and I will get it looked at, but I was hoping someone with more experience could explain what the likely cause is?


    Cheers,

    Joe

  2. #2
    Senior Member Dennis's Avatar
    Join Date
    Feb 2007
    Posts
    4,512

    Re: Issue with Giotto Evo

    Hi Joe

    It sounds like some of the seals that are in the group head at various points have perished. If you take a look at the group head assembly diagram on: http://www.espressocompany.com.au/spare-parts/ROCKET-CATALOGUE-13.03.09.pdf youll get an idea of what I mean.

    Its a little unusual to have this happen in the first year, though may be dependent on water quality and the amount of use the machine has had.

  3. #3
    Member
    Join Date
    Jan 2011
    Posts
    38

    Re: Issue with Giotto Evo

    Thanks for the advice Den.

    Quote Originally Posted by 60414A4A4D57240 link=1338809229/1#1 date=1338814688
    Its a little unusual to have this happen in the first year, though may be dependent on water quality and the amount of use the machine has had.
    The use has been mild-moderate. 2-4 a day, then 6-8 on weekends. Water is filtered with a bombora bench top system.

    This is the second seal on the machine that will need replacing.* :-?
    I woke up one morning to a kitchen full of water when the hot water wand seal decided to die. That was within the first 6 months.




  4. #4
    Senior Member Dennis's Avatar
    Join Date
    Feb 2007
    Posts
    4,512

    Re: Issue with Giotto Evo

    Quote Originally Posted by 5E7B7157140 link=1338809229/2#2 date=1338879827
    I woke up one morning to a kitchen full of water when the hot water wand seal decided to die. That was within the first 6 months.
    Was it on at the time/left on during the night?

  5. #5
    Member
    Join Date
    Jan 2011
    Posts
    38

    Re: Issue with Giotto Evo

    Quote Originally Posted by 5B7A7171766C1F0 link=1338809229/3#3 date=1338881321
    Was it on at the time/left on during the night?
    Yeah, it had been on for an hour, usual warmup timer.

  6. #6
    Senior Member Dennis's Avatar
    Join Date
    Feb 2007
    Posts
    4,512

    Re: Issue with Giotto Evo

    Oh, sorry, for a moment there I thought you might have been leaving it on 24/7.



Similar Threads

  1. Please help with a PID issue
    By DoubleCracker in forum Roasters
    Replies: 5
    Last Post: 19th November 2012, 07:00 PM
  2. EM6910 Issue
    By mcspud in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 12
    Last Post: 10th June 2010, 08:23 AM
  3. What to get when space is an issue
    By bobearth in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 7
    Last Post: 16th January 2010, 02:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •