Results 1 to 8 of 8

Thread: Expobar Ruggero Issues

  1. #1
    Member
    Join Date
    Jun 2009
    Posts
    81

    Expobar Ruggero Issues

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi All,

    Currently having a few issues with the Expobar Ruggero. The problem initially was the fact no water was coming out of the left side group head, after replacing the coil, the water is now flowing through the group ahead.

    The problem Im facing now is, the flow rate coming out of the shower screen seems too slow. Ive removed the old shower screens and replaced with brand new ones. The flow meter light flashes rather slowly, compared to the constant flash from the other group head which works fine when in operation. So my thoughts are its a problem with the flow meter, if so, do you suggest I replace the whole flow meter unit including the electrical plug that plugs into the top or do you think that all that needs replacing is the bottom part of flow meter?

    Thanks in Advance.

  2. #2
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: Expobar Ruggero Issues

    Id be looking at your water filter. What type is it, and how recently was it changed?

  3. #3
    Member
    Join Date
    Jun 2009
    Posts
    81

    Re: Expobar Ruggero Issues

    Water Filter:

    Puretec
    FPIOM

    I suggest its coming up for a replacement! Which I am in the process of.

    If you think its the water filter, how would that work, if the right group head is working fine and the left group is not.?

  4. #4
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: Expobar Ruggero Issues

    hmm yeah missed that little detail. I still dont think its the flowmeter though, a dodgy flowmeter would mess up the volumetrics but not cause a restriction at the group. Sounds like there is crud lodged somewhere in the heat exchanger or group.

    If you already replaced a burnt out coil on that group, did you open up the solenoid and check to see if the plunger was ok?

  5. #5
    Member
    Join Date
    Jun 2009
    Posts
    81

    Re: Expobar Ruggero Issues

    Have pulled off the shower screen and seal, and have given it a good clean, the valve looks clean, with no obvious signs of scum build up.

    The plunger was my next point of call, what would you suggest is happening to cause the pressure to be restricted, could the plunger be stuck half way down?

    I did notice, when a button was pressed on the control pad, a small amount of water would come out of the backflush pipe first, and within 3 seconds after that, it would come out from the group head?!

  6. #6
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: Expobar Ruggero Issues

    Its hard to say for sure where the blockage is, but its likely at or near the solenoid plunger, if it was clogged up with coffee (or scale) and not moving freely youd get the symptoms you described. Dumb question maybe, but have you tried chemically backflushing the group?

  7. #7
    Member
    Join Date
    Jun 2009
    Posts
    81

    Re: Expobar Ruggero Issues

    Will keep you posted.

    Unfortunately not a simple fix with doing a chemical backflush, machine is regularly back flushed with chemicals, wish it was as simple as this.

  8. #8
    Member
    Join Date
    Apr 2005
    Posts
    36

    Re: Expobar Ruggero Issues

    Sounds like dirt in the restrictor. Have had this issue a few times. You can remove the three way valve first. 4 allen key bolts. Turn the line pressure back on and see if it flows. Check the top of the 3 way valve to see if there is any particle there.

    Other wise undo the bolt on top of the group and pull out the restrictor tube. Should be the new style teflon ones. Check the orifice for dirt. Let the line pressure clear any dirt.

    Hope it helps.

    Martin.



Similar Threads

  1. Expobar - Ruggero, G10 and MegaCrem
    By vfxmorley in forum Brewing Equipment - Extreme Machines ($3000+)
    Replies: 6
    Last Post: 24th February 2010, 07:38 AM
  2. Expobar Ruggero ?
    By Coma11 in forum Brewing Equipment - Extreme Machines ($3000+)
    Replies: 5
    Last Post: 10th October 2008, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •