Results 1 to 4 of 4

Thread: Boema 2 group pump runs continually - help required

  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    3

    Question Boema 2 group pump runs continually - help required

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all,
    I have a slightly ageing but great 2 group Boema - see photo. It has a problem where the pump runs continually and will not cut out even though the machine appears to come up to pressure as per normal. The motor was replaced about 12 months ago with a new one from Boema. Does anyone have some ideas or advice about what could be wrong or what to do to diagnose the exact fault?
    many thks,
    Brett.


  2. #2
    Junior Member Easybarista's Avatar
    Join Date
    Jul 2012
    Posts
    20
    Maybe disconnect touchpads one at a time to possibly isolate the problem? Somewhere along the line the motor is not getting the signal to shut off regardless of what the solenoids are doing(otherwise is would be over filling. Does the machine have a control board? Sounds electrical for sure.

  3. #3
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    Quote Originally Posted by Easybarista View Post
    Maybe disconnect touchpads one at a time to possibly isolate the problem? Somewhere along the line the motor is not getting the signal to shut off regardless of what the solenoids are doing(otherwise is would be over filling. Does the machine have a control board? Sounds electrical for sure.
    thks I will give that a try and post back. Yes the machine has a Gicar control board. I'm pretty sure that the solenoids are all working - all the controls still work as well as the boiler fill. To me it appears it is failing to achieve the pressure required for cut out or for some reason the cut-out is failing.

  4. #4
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    Turned out the problem was a faulty dosage control unit (one of the 2 units at the top right hand corner). It appears that one of the internal relays is sticking. Removing the unit allows the machine to work again except no auto dosage on one group. Boema sells a replacement unit but for our purposes we're happy to have just one of the groups with auto dosage. Thanks again to Easybarista for the reply and to the tech at Boema who also suggested a couple of things.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •