Results 1 to 10 of 10
Like Tree12Likes
  • 3 Post By coffee_machinist
  • 3 Post By Vinitasse
  • 2 Post By nzcoffeetech
  • 4 Post By TC

Thread: Slow water delivery on Bezzera B2000

  1. #1
    Junior Member
    Join Date
    May 2014
    Posts
    5

    Slow water delivery on Bezzera B2000

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    I have the above 2 group machine, and the right hand group delivers water much slower than the other one. I live in a low water scale area, so that's not the problem. I was wondering if the flow could be adjusted, or if there was some sort of small filter between the boiler and the group? The mesh filter in the group head is clean, as I only changed the seal a few months ago. Thanks

  2. #2
    Junior Member
    Join Date
    May 2014
    Posts
    5
    Well, not a single reply????

  3. #3
    Member
    Join Date
    Feb 2010
    Posts
    46
    Quote Originally Posted by lesjsin View Post
    I have the above 2 group machine, and the right hand group delivers water much slower than the other one. I live in a low water scale area, so that's not the problem. I was wondering if the flow could be adjusted, or if there was some sort of small filter between the boiler and the group? The mesh filter in the group head is clean, as I only changed the seal a few months ago. Thanks
    On the top of the grouphead there is a hex cap , under there you will find a gauze filter and a restrictor jet , scale on either will be the most likely cause of your issues.

    See the exploded view - https://www.google.co.nz/search?q=be...ml%3B600%3B379

  4. #4
    Junior Member
    Join Date
    May 2014
    Posts
    5

    Thanks

    Thanks Nzcoffeetech, but as I said;
    I live in a low water scale area, so that's not the problem. I was wondering if the flow could be adjusted, or if there was some sort of small filter between the boiler and the group? The mesh filter in the group head is clean, as I only changed the seal a few months ago

    But, I will take this apart, just to see the flow is OK, so thanks.
    Les

    Quote Originally Posted by nzcoffeetech View Post
    On the top of the grouphead there is a hex cap , under there you will find a gauze filter and a restrictor jet , scale on either will be the most likely cause of your issues.

    See the exploded view - https://www.google.co.nz/search?q=be...ml%3B600%3B379

  5. #5
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683
    Snarky second guessing of FREE advice from someone with an implied high level of experience in machinery, when you clearly know little about it yourself? Way to create a good first impression. If you called me I'd go out of my way to be unavailable.
    Casa Espresso, TC and Trane like this.

  6. #6
    Senior Member Vinitasse's Avatar
    Join Date
    Aug 2010
    Location
    Mornington Peninsula VIC
    Posts
    1,251
    The aforementioned gauze filter and restrictor jet are "...between the boiler and the group" and above the shower screen and seal you keep on yacking about.

    Expert advice has already been given so you might want to consider actually looking at the parts diagram:

    TC, Trane and lesjsin like this.

  7. #7
    Member
    Join Date
    Feb 2010
    Posts
    46
    Regardless of how good your water ( or any filtration is ) there will always be minerals in the water , mineralised water in a boiler will always leave sediments to some degree.

    There is no flow adjustment , you WILL have a blockage somewhere , most likely where I mentioned or possibly the inlet jets on the flowmeters.
    Trane and lesjsin like this.

  8. #8
    Junior Member
    Join Date
    May 2014
    Posts
    5
    Thanks very much for this NZ and Vinitasse, I WILL strip it and have a look. PS - 'coffee machinist' - I WAS NOT being 'snarky' (or 'sarky' - short for sarcastic - but I AM being now, and don't worry, I wouldn't be calling YOU out with that attitude), I was simply trying to eliminate things like lime scale, but as NZ has said there are other deposits - fair comment, and for that I am grateful.

  9. #9
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Welcome lesjin,

    So far, you're not making too many friends here.

    Might I suggest that you take a big, deep breath and then start again?

    It's best to leave a bad day and/or the attitude at the door as you enter. You're much more likely to receive the (free) assistance you need that way.

  10. #10
    Junior Member
    Join Date
    May 2014
    Posts
    5
    Point taken, sorry if I sounded a bit rude :-(
    Anyway, this morning I stripped the group head & cleaned it (it was pretty clean though, as I use Puly every night. I also took out the small metal filter under the nut on top. I doused it in a strong Puly solution for a couple of hours, re-assembled it, and it is now running at the same rate as the other group.
    Thank you for your help, it really IS appreciated.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •