Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By TC

Thread: La Marzocco GS3 Servicing - Brisbane

  1. #1
    Senior Member
    Join Date
    Aug 2007
    Posts
    569

    La Marzocco GS3 Servicing - Brisbane

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    All

    Bad day to try and replace your GS3 MP seals. Have not managed to get it all working again without leaks (have done so successfully in the past). As far as I can tell I have done everything right, so worried it is something else.
    Have exceeded my skills after reviewing schematics, videos and other people's posts on various forums.
    Had to use the faithful old aeropress on New Years day.

    Does anyone have a recommended La Marzocco GS3 service company in Brisbane (I am in Bardon). I have looked through sponsors list and did not see anything.
    Please PM so you don't breach any posting policies.

    thanks
    Ben

  2. #2
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Hi Ben,

    It's easy to to damage if you don't do the job properly. If you do your own, you really need an o-ring removal tool or you can risk damage.
    Col3 likes this.

  3. #3
    Senior Member
    Join Date
    Aug 2007
    Posts
    569
    Hi

    I actually have one.
    When you say damage - do you mean the the metal components between the o-rings, as when you put them back, you don't use the tool, but rather then blue spindle shaft.
    One other avenue, is I have the new dupont o-rings, with the old spindle which I understand you need to upgrade.

    Ben

  4. #4
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Hi Ben,

    Haven't tried the newies, but sounds like you're onto the issue.

    Chris

  5. #5
    Senior Member
    Join Date
    Aug 2007
    Posts
    569
    Quote Originally Posted by Talk_Coffee View Post
    Hi Ben,

    Haven't tried the newies, but sounds like you're onto the issue.

    Chris
    Put some of the old ones (least damaged) back in.
    Same issue.

    Off to some professionals on monday!

    I am interested to understand if the new o rings will work with the old spindle / metal rings (will mail LM to see what they say)

  6. #6
    Senior Member
    Join Date
    Aug 2007
    Posts
    569
    Root cause of issue - I had damaged the exhaust valve thread (they managed to remove three threads and re-use). Apparently better to loosen exhaust valve when adjusting to be able to line it up. Looks very easy in the LM video, but I really struggled with it, and thought it may have been the issue. Have not seen any reference to needing to do this in any literature and would need a very long ratchet piece to do this.

    LM Australia recommend completely changing out the spindle/ spacers etc with the new seals, but mine currently is working with the new seal kit. Will be interested to see if they last any longer.

    Expensive lesson!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •