Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By coffee_machinist

Thread: Alex (Gicar) PID LED segment failure

  1. #1
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,418

    Alex (Gicar) PID LED segment failure

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    An LED segment has stopped working on the PID display on my Alex Duetto II (the blue coloured one of that makes a difference). A bit of a PITA.

    Is this fixable?

    Cheers

  2. #2
    Member
    Join Date
    Jul 2016
    Location
    Perth, WA
    Posts
    38
    I looked at a second hand Alex PID that was onto its third Gicar display, and even it was missing a segment! So my guess is it's an ongoing issue.

  3. #3
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,418
    Yeah I have read about others having the same problem. Just wondering if the LED display is fixable or not. I'd imagine it wouldn't be an easy task.

    Cheers

  4. #4
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683
    It's very doable with the correct replacement display and a desoldering station handy. That first part is easier said than done though sadly.
    Dimal likes this.

  5. #5
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,418
    Thanks Rick.

    Cheers

  6. #6
    Member Morgz's Avatar
    Join Date
    Dec 2009
    Location
    Perth
    Posts
    96
    Quote Originally Posted by artman View Post
    An LED segment has stopped working on the PID display on my Alex Duetto II (the blue coloured one of that makes a difference). A bit of a PITA.

    Is this fixable?

    Cheers
    Same thing happened to me so I got a new one installed. Wasn't too expensive.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •