Results 1 to 2 of 2

Thread: Faema E61 Gauges Don't seem to work

  1. #1
    Junior Member
    Join Date
    Jun 2019
    Posts
    1

    Faema E61 Gauges Don't seem to work

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi members.

    Does anyone have and experience with coffee machine gauges?

    I recently descaled my badly scaled Faema E61 with success but it seems my gauges aren't working. I wanted to know if there was anyway to check if it's definitely the gauges that are shot before I buy some new ones. I've have the back off the gauges and sprayed with silicone spray but seems like this hasn't done anything. I've had the guage pipes off and blown through the so don't seem blocked.

    The boiler seems to get up to temp fine and group head etc and I have pulled half decent shots through the machine but would obviously like to get everything working like new. I suppose I could live without then if I can test through portafilter pressure gauge.

    Any advice would be much appreciated.

    Cheers,
    Steve

  2. #2
    Senior Member
    Join Date
    Apr 2007
    Location
    Sydney - Northern Beaches
    Posts
    398
    Sometimes the descale procedure results in small chunks of scale breaking loose and finding their way into some of the tighter areas of the machine like the glicuer or possibly the bourbon tube of a gauge. Im not saying this has happened but its a possibility given that they stopped working after a machine descale. Not sure if you can get descale solution into somewhere like that, or what that might do to the gauge long term, but I guess if they are going to be replaced otherwise, you don't have much to loose.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •