Results 1 to 3 of 3
Like Tree2Likes
  • 2 Post By Thirteen13

Thread: Profitec Pro 600 tight brew lever

  1. #1
    Senior Member Thirteen13's Avatar
    Join Date
    Feb 2012
    Posts
    448

    Profitec Pro 600 tight brew lever

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello,

    I took the main screw (part called Flange) that holds the cam shaft (axis brew group part 5) off to give a little grease to smooth it up and ive noticed the brew lever is getting very tight to turn. So tight is it, that it simply spin the main screw rather than the cam shaft rotating within the main screw. I've checked the diagram of the part and it doesnt appear as if anything could be causing it to become and issue. Looking down the flange body as its assembled and everything is straight, there doesnt appear to be a tight gap and i assume from the spring (Part 7) within the flange group that would allow part 36 to freely move to centre itself with the axis group (part 5)

    It is starting to become so tight that rather than the cam shaft turning within the main screw, it will twist the screw undone.

    shaft.png

    Any ideas?
    Last edited by Thirteen13; 2 Weeks Ago at 10:05 PM.

  2. #2
    Senior Member Thirteen13's Avatar
    Join Date
    Feb 2012
    Posts
    448
    I think i might have solved it, but good for others to know.

    Without disasembling the flange (because i dont have a skinny 32mm spanner @ 11pm) it looks like it is either a rubber seal or a tight fit, but i removed the cam shaft completely and to reseat it, pressed the cam shaft in the other direction and it seems like it could have pushed the seal back into place.
    Dimal and flynnaus like this.

  3. #3
    Senior Member Thirteen13's Avatar
    Join Date
    Feb 2012
    Posts
    448
    Machine switches on at 6am and had 30 minutes to heat up before i used it and lever was butter smooth. So really unsure why it was so tight, but i assume something wasnt seated correctly. All is good and all is smooth. Machine works great.

    One hot tip is, pull the mushroom valve out. I think my machine is about 6 months old and used many times per day, I used super soft water and im still getting crud built up on the valve body, spring and the other valve within the top of the head. There is alot of grit sculling around in there too, so good oppurtunity to scrub it out. Takes a total of 10 minutes to clean it all out.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •