Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By artman

Thread: Old Faema "no stop" brew pressure problem

  1. #1
    Senior Member
    Join Date
    Jul 2006
    Posts
    243

    Old Faema "no stop" brew pressure problem

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi Guys,

    I have a very old Faema "No Stop" and im encountering a weird problem where I think its lacking brew pressure, but the guage is broken so I can't check it, and I also don't have a portafilter guage.

    The reason I have decided its lacking pressure is because almost no crema is being produced, and unless I make the grind super coarse, it takes forever to push out the usual amount of water.

    The other weird thing I have noticed, is that during the extraction process, water is running out of the drain/blow off valve at the back of the group in use. I am not sure if this is supposed to happen in some form on this machine as its not my regular machine, and I'm not sure if this is just a byproduct of this machine not having group solenoids like my Cimbali M21.

    I should say, I have tried turning the pressure adjustment screw on the pump clockwise about as far as it will tighten, and it hasn't had any noticeable effect.

    If this was happening on my Cimbali, I'd presume the group solenoid needed cleaning or replacing (or at least the valve), but because this machine doesn't have one, I am at a loss.

    Is it the various springs that need replacing instead? I dont even really know how this group functions aside from the exploded parts diagram on CP. (https://www.coffeeparts.com.au/parts...nostop-compact)


    Is anyone able to shed some light on this?


    Thanks in advance,

  2. #2
    Senior Member Jackster's Avatar
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    1,114
    Water runs out of the drain.

    This is your first issue, it should not. It will be full of old coffee grinds and oils, making it leak. Pull apart the valving to clean, or maybe a good back flushing will clean it.

  3. #3
    Senior Member
    Join Date
    Jul 2006
    Posts
    243
    Yep, this definitely seems to be the issue.

    I pulled the group apart and all the seals in the "exhaust" part of the group are almost completely gone. I swapped the relevant parts from the right group to the left group (just to verify) and whilst they are in poor condition as well, they were better, and that massively improved things. Water still comes out the drain, but much less.

    Given its a fully mechanical 3-way valve, I am just going to order a complete set of the replaceable parts from CP and rebuild both groups.

    Thanks for your help.

    Also, just in case anyone else has a similar problem, I found the video in this thread of a cutaway E61 group head (slightly different to the no stop) really helpful in showing how the mechanical 3-ways operate. https://www.home-barista.com/espress...ad-t25154.html

  4. #4
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,476
    On my old feama/cimbali with rotary pump, the brew pressure piston in the pump head was stuck, and hence the adjustment screw had no effect (it normally adjusts the spring pre load). Remove the adjuster assembly, free the piston, clean piston and bore and relube, then replace. Worth checking.

    On mine it was stuch in a high pressure position, and the pump has way more flow than the circuits can handle, everytime the pump activated it dumped all the excess water out of the over pressure valve, and it was a lot of volume!

    Cheers
    Dimal likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •