Results 1 to 19 of 19

Thread: Miss Silvia is not pumping well through the group head

  1. #1
    Junior Member
    Join Date
    Jan 2009
    Posts
    1

    Miss Silvia is not pumping well through the group head

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    I have a 4 yr old Miss Sylvia that I maintain by descaling and backflushing as various posts suggest. Of late the following has occurred. The flow through the group head has reduced and to get a decent shot I need to run it for 30 + seconds despite the grind, and as you can imagine the taste is not up to scratch and there is no crema. The frothing wand is great and heats milk for my latte as well as usual.

    Any advice of what the issue is?

    Also if it needs a service where do I send/take it? I live in Newcastle NSW.

    cheers ... * ;)

  2. #2
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 283F343337303D285C0 link=1238283886/0#0 date=1238283886
    I have a 4 yr old Miss Sylvia that I maintain by descaling and backflushing as various posts suggest. Of late the following has occurred. The flow through the group head has reduced and to get a decent shot I need to run it for 30 + seconds despite the grind, and as you can imagine the taste is not up to scratch and there is no crema. The frothing wand is great and heats milk for my latte as well as usual.

    Any advice of what the issue is?

    Also if it needs a service where do I send/take it? I live in Newcastle NSW.

    cheers ... * ;)
    Howdy and welcome...

    Have a read over http://www.coffeeco.com.au/articles/repair.html

    <<<< Its possibly a good idea to have it serviced if its 4 years old.

    Im sure that Charlie at Jetblack or Renzo at DiBartoli (site sponsor) will be happy to assist if youre prepared to have a drive?

    Good luck

    2mcm

  3. #3
    Site Sponsor
    Join Date
    May 2008
    Location
    Frenchs Forest NSW
    Posts
    760

    Re: Miss Silvia is not pumping well through the group head

    We service Silvias too if Cremorne is more convenient,

    charlie

  4. #4
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 456A7B4D636E6C644C6E696A0F0 link=1238283886/2#2 date=1238291217
    We service Silvias too if Cremorne is more convenient,

    charlie
    Whoops Charlie :-[.. Previous post amended ;)

  5. #5
    Member
    Join Date
    Oct 2007
    Posts
    69

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 30272C2B2F282530440 link=1238283886/0#0 date=1238283886
    I have a 4 yr old Miss Sylvia.......The flow through the group head has reduced and to get a decent shot I need to run it for 30 + seconds despite the grind, and as you can imagine the taste is not up to scratch and there is no crema...............cheers ... * ;)

    Is the flow thru the group reduced (in comparison to what it used to be) when the machine is sans porterfilter OR, when you are brewing coffee?

    If the flow is reduced when you are sans porter filter, take a look at the bypass tube in the tank. Is there a scheit load of water bypassing back to the tank ie more than you used to get>????????????????????

    Alternately if the flow is only reduced when you are brewing coffee, have you recently changed coffee bean supply or blend?


  6. #6
    Member
    Join Date
    Aug 2005
    Posts
    41

    Re: Miss Silvia is not pumping well through the group head

    Im starting to have this issue as well.
    Im wondering if you have any update on your issue?
    Thanks

  7. #7
    Senior Member
    Join Date
    Jan 2007
    Posts
    541

    Re: Miss Silvia is not pumping well through the group head

    I had [possibly] similar issues at about the 4 year mark.
    In my case, I could hear the pump slow down, struggle and basically stop through a shot.
    When healthy you could run a blind filter and not hear the pump struggle.

    I replaced the pump.....very easy job, takes <15min and a new pump costs $50ish.

    WRT your problem, does your pump sound "strong" throughout the shot or can ypu hear it struggle....if so replace it and see how you go.

  8. #8
    Senior Member
    Join Date
    Apr 2009
    Location
    Republic of China
    Posts
    162

    Re: Miss Silvia is not pumping well through the group head

    I saw the ULKA pump on coffeeparts.com for about 100 bucks.

  9. #9
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 2D242F303233293F32246F6D6D5D0 link=1238283886/7#7 date=1240354485
    I saw the ULKA pump on coffeeparts.com for about 100 bucks. *
    If it is the standard EP5 I have a couple just lying around :-)

  10. #10
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: Miss Silvia is not pumping well through the group head

    Most ulka pumps are under 100 bucks this days.

    http://www.dibartoli.com.au/product_details.asp?pid=198

    http://www.coffeeparts.com/misc/vibratingpumps.html

    Let us know if we can be of any help.

    Regards


    Renzo

  11. #11
    Senior Member
    Join Date
    Apr 2009
    Location
    Republic of China
    Posts
    162

    Re: Miss Silvia is not pumping well through the group head

    Renzo

    About a month ago Ofra was on here offering up a Silvia maintenance pdf to anyone who emailed. I emailed through but never heard anything back. Is this still available ?

    Many thanks


  12. #12
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 5E575C4341405A4C41571C1E1E2E0 link=1238283886/10#10 date=1240359558
    Renzo

    About a month ago Ofra was on here offering up a Silvia maintenance pdf to anyone who emailed. I emailed through but never heard anything back. Is this still available ?

    Many thanks
    Have you looked here... http://homepage.mac.com/jrc/contrib/rancilio_silvia/

    It is a reasonable resource and references those that have contributed and or assisted etc..

  13. #13
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: Miss Silvia is not pumping well through the group head

    Sure, not a problem shoot me a email with all your detais and I will send it to you. my direct email is renzo@dibartoli.com.au.

    regards


    Renzo

  14. #14
    Senior Member
    Join Date
    Apr 2009
    Location
    Republic of China
    Posts
    162

    Re: Miss Silvia is not pumping well through the group head

    Thanks Anger,

    I have run across that site on Google before, but most of the maintenance links are dead links. The section on brewing shots and steaming milk is good though. The best reference so far is probably the coffeeco website. Although some of it is a bit over the top, like remove the shower screen every week and clean!

  15. #15
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 3138332C2E2F35232E38737171410 link=1238283886/13#13 date=1240444678
    Thanks Anger,

    I have run across that site on Google before, but most of the maintenance links are dead links. *The section on brewing shots and steaming milk is good though. *The best reference so far is probably the coffeeco website. Although some of it is a bit over the top, like remove the shower screen every week and clean!
    Some might do this daily *;)

    See http://www.jetblackespresso.com.au/equipment/rancilio-silvia/cleaning-the-rancilio-silvia/

    It all depends on usage and how you use it... *If up dosing and fine, then more than less..

    I did have another site out of CaNaDa but just can not fine it at present..

    AM

  16. #16
    Member
    Join Date
    Aug 2005
    Posts
    41

    Re: Miss Silvia is not pumping well through the group head

    I have tested the pump flow after reading http://coffeesnobs.com.au/YaBB.pl?num=1230288281, and I got 150ml in 30secs.
    So I think the pump is ok.

    could it be the OPV?

  17. #17
    Senior Member
    Join Date
    Mar 2006
    Posts
    703

    Re: Miss Silvia is not pumping well through the group head

    I once had problems with Silvia just after I had de-scaled the boiler.
    A piece of scale got into the three way valve and it wasnt working properly, which could cause apparently reduced flow when brewing, (some actually leaking into the drip tray) even with a satisfactory no load flow rate as noted above.

    Pulling the three way valve out, and cleaning it out is relatively strait-forward. There is, or was, an illustrated how to available on the net several years ago, might even be a few by now.

    If that doesnt help, maybe you need some help from a sponsor.

  18. #18
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: Miss Silvia is not pumping well through the group head

    Quote Originally Posted by 7F4851515449493D0 link=1238283886/16#16 date=1240528278
    I once had problems with Silvia just after I had de-scaled the boiler.
    A piece of scale got into the three way valve and it wasnt working properly, which could cause apparently reduced flow when brewing, (some actually leaking into the drip tray) even with a satisfactory no load flow rate as noted above.

    St33p;

    backflash with water only a few times, and see make any changes

    regards

    Renzo

  19. #19
    Member
    Join Date
    Aug 2005
    Posts
    41

    Re: Miss Silvia is not pumping well through the group head

    Ive tried backflushing with water only and later dismantling the three way valve - none of it solve the issue :(
    Any other idea?

    thanks,
    Harry



Similar Threads

  1. Rancilio Silvia V3 - Steam from group head - need help!
    By rnm1985 in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 8
    Last Post: 20th December 2011, 11:26 AM
  2. Miss Silvia Leaking from group head
    By shortmac in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 4
    Last Post: 11th September 2011, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •