Results 1 to 7 of 7

Thread: gaggia classic

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    12

    gaggia classic

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hey all,

    Just got a 2nd hand classic this week, gave it a few test runs with some old coffee to see if it worked then went out today to get the silvia steam want a new tamper some freshly ground goodness and a pitcher.

    First shot went alright, was blonding quite early but still produced a tasty coffee, 2nd shot water began to leak from the portafilter edges and again on the 3rd but not as badly. Im guessing it could be the gasket?

    Also after steaming the milk, steam still slightly seeps from the wand for a minute or so, is this normal?

    thanks

  2. #2
    Junior Member
    Join Date
    Jul 2009
    Posts
    24

    Re: gaggia classic

    Sounds very much like a gasket to me. I ordered one this week from Coffee Parts (one of the sponsor links on the left hand side :) Mine was going much the same. Replaced the gasket and no problems.

    As for the millk issue I assume you still have the original steam wand? I would imagine this would be normal due to the wand perhaps sucking a bit of milk up when you turn it off. Ive modded my classic with the silvia wand and it doesnt do that. A good wipe afterwards sorts that out.

  3. #3
    Senior Member
    Join Date
    Oct 2008
    Posts
    488

    Re: gaggia classic

    As markso said, replacing the group head seal with fix that leak. In regards to the steam, it may be a seal in the steam valve assembly. Again, Coffee Parts will be your friend. Ask Pedro for any help you require.

    Cheers,
    Ben

  4. #4
    Junior Member
    Join Date
    Jan 2010
    Posts
    12

    Re: gaggia classic

    Quote Originally Posted by 262A392038244B0 link=1263477904/1#1 date=1263510534

    As for the millk issue I assume you still have the original steam wand? I would imagine this would be normal due to the wand perhaps sucking a bit of milk up when you turn it off. Ive modded my classic with the silvia wand and it doesnt do that. A good wipe afterwards sorts that out.

    nahh i have the silvia wand, its done it with both, i usually just let out some steam for a about 5 seconds after wards, but i think ill give coffee parts a call or msg.

  5. #5
    Junior Member
    Join Date
    Jan 2010
    Posts
    12

    Re: gaggia classic

    could the gasket problem be causing channeling? or am i not tamping with enough force?

    its stopped leaking after i cleaned some grounds away from around the screen. that could have been the problem.

    but the wand problem has worsened, it only used it about 3 times before replacing it with the silvia wand. now today it drips a few drops of water while the machine heats up and also leaks a slow stream of steam after using it and yeah i think its also sucking up a bit of milk im not sure.

  6. #6
    Senior Member
    Join Date
    Oct 2008
    Posts
    488

    Re: gaggia classic

    So Im guessing youve called Coffee Parts and exhausted all possibilities to do with an issue with the steam valve?

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    12

    Re: gaggia classic

    ordered steam valve and gasket seal from di bartoli.

    hopefully will fix the prob.

    thanks guys!



Similar Threads

  1. Replies: 6
    Last Post: 15th March 2012, 09:20 PM
  2. Replies: 4
    Last Post: 10th December 2011, 12:23 PM
  3. Gaggia Classic portafilter and GAGGIA PROTEO ROMANZA
    By cazby in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 0
    Last Post: 24th October 2011, 06:50 PM
  4. Replies: 6
    Last Post: 23rd November 2009, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •