Results 1 to 8 of 8

Thread: Sunbeam 6910 weak steam......please help!

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Posts
    11

    Sunbeam 6910 weak steam......please help!

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Help!.......I have a Sunbeam 6910 just out of warranty, it has decided to make weak steam, stuffing up my frothing. Previously I had no problems and havent fiddled with it. Any suggestions?

  2. #2
    Senior Member
    Join Date
    Jun 2009
    Posts
    214

    Re: Sunbeam 6910 weak steam......please help!

    Hi Albad,

    When was the last time you black flushed or descaled your machine? :-?

  3. #3
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Sunbeam 6910 weak steam......please help!

    Quote Originally Posted by 7A77797A7F1B0 link=1270266191/0#0 date=1270266191
    Help!.......I have a Sunbeam 6910 just out of warranty, it has decided to make weak steam, stuffing up my frothing. *Previously I had no problems and havent fiddled with it. *Any suggestions?
    Try reading the many posts on this issue....

    If the pump = Warranty

    If your lack of maintenance etc = You pay

    Where are you located ?

  4. #4
    Junior Member
    Join Date
    Apr 2010
    Posts
    11

    Re: Sunbeam 6910 weak steam......please help!

    Thanks for that. I found other posts after posting mine (newbie!) and decided to descale the steam side (despite Sunbeams manual) with great results. Thanks everyone!

  5. #5
    Senior Member
    Join Date
    Apr 2008
    Posts
    370

    Re: Sunbeam 6910 weak steam......please help!

    !!!!???? YOU DESCALED THE STEAM WAND????

    Wouldnt that seriously stuff up the thermoblock? I mean, youre evaporating off descaler solution inside it.

  6. #6
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Sunbeam 6910 weak steam......please help!

    Quote Originally Posted by 3A252D3E333632325F0 link=1270266191/4#4 date=1270914844
    !!!!???? *YOU DESCALED THE STEAM WAND????

    Wouldnt that seriously stuff up the thermoblock? I mean, youre evaporating off descaler solution inside it.
    NO not at all, if done correctly. The Service agents have to do it all teh time..

    If ya read the method.... The main issue is for YOU the user. Thus, SB put that in there to protect them selves..

    Thats why you change wetness and temp and do it out side and then flush and flush again... If ya stand over it and breath in deep.. Well who is to blame..

    Have a read of any de-scaler warnings, even doing the main system and group head you get some steam... Just not so much... And it;s a thermoblock as well...

    In addition, it is usually a last ditched attempt to recover a dead or almost dead unit due to scale / coffee grinds that have gotten into the system.

    PS. Cut ya Steam thermoblock in half and have a look... You might be surprised.....








  7. #7
    Senior Member
    Join Date
    Apr 2008
    Posts
    370

    Re: Sunbeam 6910 weak steam......please help!

    I know how to change the wetness and temperature... but what do you mean by "do it outside" and "flush and flush again"?

  8. #8
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Sunbeam 6910 weak steam......please help!

    Do it out side = do the process out side.. *On deck or else where where it is well vented. Read the warnings on any cleaning product. Some are more sensitive than others.

    Flush = just that... *After you have run ya solution a few times.. * Some short bursts etc leave for a few min 5 or even 10, then run the steam again. *Toucan also do the group at the same time.

    When ya happy.. As per any cleaning , even a back flush.. *You need to flush with clean water.

    With the steam wand, you need to put on a clean tank of water and flush the group.. Follow the manual as to key presses etc

    But you also need to make sure the steam pump and lines are flushed. *Ie run a few runs with the clean water.. Sit for a few min and run the steam again..

    If it stinks of de scaler keep flushing...

    Change ya water again, another quick manual shot and steam. If happy re set ya steam temp and wetness to where you want it.

    Do I do it that way.... *Once I did, but depending on what the problem is, there are other ways if you have the tools.



Similar Threads

  1. 6910 very wet, weak steam
    By perko88 in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 46
    Last Post: 12th March 2014, 11:57 AM
  2. Sunbeam 6910 steam quality
    By Phil_Jones in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 8
    Last Post: 24th July 2012, 06:40 PM
  3. My Sunbeam EM 6910 running out of steam
    By crazyhakins in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 2
    Last Post: 12th July 2010, 10:38 PM
  4. Sunbeam 6910 - no steam!!! HELP!
    By Mochamaker in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 6
    Last Post: 10th June 2008, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •