Results 1 to 12 of 12

Thread: Amusing new EM6910 Problem

  1. #1
    Junior Member
    Join Date
    Mar 2009
    Posts
    13

    Amusing new EM6910 Problem

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Thankfully this problem does not affect the operation of the device. But.

    Theres a thing in the base of the machine that catches the water from what I assume is some sort of cleaning process. Ah, but guess what? Sunbeam did a little fiddle with the 6910 between January and April when we bought a second to replace the first, and the new arrangements means the cleaning process dumps the water in the base rather than the drip tray./\/

    Anyone else seen this? We seat the tray firmly but after a few uses get a dribble of dirty water and after lifting the tray out find a puddle like the one left behind by a brat in Coles the other night. Thankfully not the same colour...

  2. #2
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 1B04130E0604041609081B610 link=1247553824/0#0 date=1247553824
    Thankfully this problem does not affect the operation of the device. But.

    Theres a thing in the base of the machine that catches the water from what I assume is some sort of cleaning process. Ah, but guess what? Sunbeam did a little fiddle with the 6910 between January and April when we bought a second to replace the first, and the new arrangements means the cleaning process dumps the water in the base rather than the drip tray./\/r

    Anyone else seen this? We seat the tray firmly but after a few uses get a dribble of dirty water and after lifting the tray out find a puddle like the one left behind by a brat in Coles the other night. Thankfully not the same colour...
    There has been a few issues with the length of the tube and the way the drip tray sits..

    Has been posted before and some interesting fixes have been implemented..

    I have not seen the problem... But know that it does happen.

    Some cleaver searching of old posts may find a solution for you..

    AM

  3. #3
    Senior Member
    Join Date
    Feb 2009
    Location
    North Rothbury, NSW
    Posts
    1,104

    Re: Amusing new EM6910 Problem

    We bought ours in Feb and dont have that problem.

    We may get a small amount under the tray but only when it is quite full.

    Does your new one have the round red waste level indicator of the narrow straight one?

    Ours id the straight one which I assume is the later model, though unsure of when they changed them.

  4. #4
    Junior Member
    Join Date
    Jul 2009
    Posts
    4

    Re: Amusing new EM6910 Problem

    yeah... i bought a 6910 2 weeks ago (good guys castle hill, nsw - never going there again).. get a little moisture under the tray. i empty the tray constantly.. tray seems to line up.. maybe theres a gap.not too concerned


    what i want to know is if anybody gets steam coming out of the tray (from the drain i guess) whilst its warming up... not constant, just a little cloud.. kinda eerie..

  5. #5
    Senior Member
    Join Date
    Sep 2008
    Posts
    759

    Re: Amusing new EM6910 Problem

    Skullf...

    I get both issues since I bought my machine 12 months ago. No issue as far as Im concerned.

  6. #6
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 53515D55555B5C41320 link=1247553824/4#4 date=1247828702
    Skullf...

    I get both issues since I bought my machine 12 months ago. No issue as far as Im concerned.
    Agree...

  7. #7
    Senior Member
    Join Date
    Feb 2009
    Location
    North Rothbury, NSW
    Posts
    1,104

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 455D435A5A5057445D360 link=1247553824/3#3 date=1247825686
    yeah... i bought a 6910 2 weeks ago (good guys castle hill, nsw - never going there again)..
    Why?

  8. #8
    Senior Member Rusty's Avatar
    Join Date
    Apr 2004
    Location
    Carlingford NSW
    Posts
    691

    Re: Amusing new EM6910 Problem


    Quote Originally Posted by 756D736A6A6067746D060 link=1247553824/3#3 date=1247825686
    what i want to know is if anybody gets steam coming out of the tray (from the drain i guess) whilst its warming up... not constant, just a little cloud.. kinda eerie..
    Quite normal part of the warming up process.

    I kinda like it ;D

  9. #9
    Junior Member
    Join Date
    Jul 2009
    Posts
    4

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 3F372F25385C0 link=1247553824/6#6 date=1247884056
    Quote Originally Posted by 455D435A5A5057445D360 link=1247553824/3#3 date=1247825686
    yeah... i bought a 6910 2 weeks ago (good guys castle hill, nsw - never going there again)..
    Why?
    Bought a A/C back in january.. had it delivered, boxes looked a little rough.. electrician came out to install..didnt work.turns out it had been dropped and the insides had come off there mounts and more.. then, bought 6910 (on back order). all the boxes on the trading floor were pristine, the one they gave us had dents and holes and so on.kicked up a stink and got one of the ones on the floor. talk about hassle

  10. #10
    Junior Member
    Join Date
    Jul 2009
    Posts
    3

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 756A7D60686A6A786766750F0 link=1247553824/0#0 date=1247553824
    Thankfully this problem does not affect the operation of the device. But.

    Theres a thing in the base of the machine that catches the water from what I assume is some sort of cleaning process. Ah, but guess what? Sunbeam did a little fiddle with the 6910 between January and April when we bought a second to replace the first, and the new arrangements means the cleaning process dumps the water in the base rather than the drip tray./\/r

    Anyone else seen this? We seat the tray firmly but after a few uses get a dribble of dirty water and after lifting the tray out find a puddle like the one left behind by a brat in Coles the other night. Thankfully not the same colour...
    Hi, I have the same problem, however mine started after giving the machine a major backflush/ clean/ descale a couple of months ago.
    During one of the backflushes it didnt "vent" normally, and since then the dirty water gathers under the drip tray (most goes in it...) and it also leaks out onto the benchtop from a couple of points under the machine. Just a dribble, however enough that I have just logged an extended waranty claim (machine was bought 6/2007). I will have a bit of a scan to see if I can find a simple solution... I dont want to be without it for too long if I can help it!
    Cheers,
    Dave

  11. #11
    Senior Member Magic_Matt's Avatar
    Join Date
    Sep 2007
    Location
    Northlandia
    Posts
    1,365

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 130B150C0C0601120B600 link=1247553824/3#3 date=1247825686
    yeah... i bought a 6910 2 weeks ago (good guys castle hill, nsw - never going there again).. get a little moisture under the tray. i empty the tray constantly.. tray seems to line up.. maybe theres a gap.not too concerned


    what i want to know is if anybody gets steam coming out of the tray (from the drain i guess) whilst its warming up... not constant, just a little cloud.. kinda eerie..
    My first EM6910 (manufactured in 2007) had the drip-tray problem - essentially the brass nozzle was misaligned so the outflow missed the tray. That was fixed by the service center when I took it in for something else.

    Both of my 6910s have vented steam from the drip tray while warming up - this comes from the same outflow and is normal behaviour AFAICT...

    Quote Originally Posted by 55706774202322110 link=1247553824/9#9 date=1248059660
    Quote Originally Posted by 756A7D60686A6A786766750F0 link=1247553824/0#0 date=1247553824
    Thankfully this problem does not affect the operation of the device. But.

    Theres a thing in the base of the machine that catches the water from what I assume is some sort of cleaning process. Ah, but guess what? Sunbeam did a little fiddle with the 6910 between January and April when we bought a second to replace the first, and the new arrangements means the cleaning process dumps the water in the base rather than the drip tray.


    Anyone else seen this? We seat the tray firmly but after a few uses get a dribble of dirty water and after lifting the tray out find a puddle like the one left behind by a brat in Coles the other night. Thankfully not the same colour...
    Hi, I have the same problem, however mine started after giving the machine a major backflush/ clean/ descale a couple of months ago.
    During one of the backflushes it didnt "vent" normally, and since then the dirty water gathers under the drip tray (most goes in it...) and it also leaks out onto the benchtop from a couple of points under the machine. Just a dribble, however enough that I have just logged an extended waranty claim (machine was bought 6/2007). I will have a bit of a scan to see if I can find a simple solution... I dont want to be without it for too long if I can help it!
    Cheers,
    Dave
    Hey Dave, youll likely find that the outlet tube from the three-way valve has become disconnected at one of its junction points. This happened to my first 6910 and after several fruitless trips to the local service agent to have it fixed, it was replaced by Sunbeam. IMHO you should immediately cease using the machine, as 240v + water + you is a very bad combination!

  12. #12
    Junior Member
    Join Date
    Jul 2009
    Posts
    3

    Re: Amusing new EM6910 Problem

    Quote Originally Posted by 4A67270 link=1247553824/10#10 date=1248143916

    Hey Dave, youll likely find that the outlet tube from the three-way valve has become disconnected at one of its junction points. This happened to my first 6910 and after several fruitless trips to the local service agent to have it fixed, it was replaced by Sunbeam. IMHO you should immediately cease using the machine, as 240v + water + you is a very bad combination!
    Thanks for the "heads-up" M@... it is going in on Saturday for some TLC...



Similar Threads

  1. EM6910 problem...
    By rooeey in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 4
    Last Post: 3rd June 2012, 09:00 AM
  2. Amusing video
    By greenman in forum Off Topic
    Replies: 3
    Last Post: 31st January 2011, 10:48 PM
  3. Amusing New York Times item
    By tojo1 in forum General Coffee Related...
    Replies: 0
    Last Post: 4th December 2008, 02:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •