Results 1 to 5 of 5

Thread: EM 6910 advice needed

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    1

    EM 6910 advice needed

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi there,
    We have had a Sunbeam 6910 for a couple of years and recently a problem has started to occur with the steam wand. Basicly when we turn of the steam to the wand, it keeps issuing steam for quite a while (approx up to 30 secs). does anyone have any solutions to this problem or is this normal. If machine is needing a service who would people recommend in Adelaide to do the job?
    I might be willing to give a go myself if it is reasonably easy to pull machine apart. :)

  2. #2
    Caffeine Junky
    Join Date
    May 2009
    Posts
    1,103

    Re: EM 6910 advice needed

    Theres only one authorised Sunbeam dealer in SA, located in Park Holme. They were OK when my 6910 needed repairing, but very slow. You can get their details off the Sunbeam website, otherwise PM me.

    Coffee Craft used to repair Sunbeams but unfortunately no longer do. I would much rather have used them given the choice.

    I believe your problem is not uncommon. A search of the forum would probably reveal fixes for it. Otherwise Anger Management (our resident 6910 guru) will probably be along shortly to advise.


  3. #3
    Senior Member
    Join Date
    Mar 2008
    Posts
    433

    Re: EM 6910 advice needed

    mine does the same sometimes, seems to be when its on a dry steam setting more than wet (valve not closing properly?)

    You can "try" running scale solution through it, set steam thermoblock to coolest and steam to wettest, and only do it outside (maybe use the vinegar solution rather than a chemical one?) then run the steam at your normal settings a few times before using on milk agian.

    AM may be along soon with some other thoughts also

    Sen

  4. #4
    Senior Member Stan's Avatar
    Join Date
    Dec 2007
    Location
    Just North of Brisbane
    Posts
    943

    Re: EM 6910 advice needed

    I had the same problem - used a descaler (not sunbeam) and ran it through the wand - problem fixed. The sunbeam descaler comes with a warning not to run it through the steam - but I got a commercial descaler which is approved for food devices. Some of the sponsors sell similar products.

    Hope this helps.

  5. #5
    A_M
    A_M is offline
    Guest
    Join Date
    Mar 2006
    Posts
    6,381

    Re: EM 6910 advice needed

    Quote Originally Posted by 64435659370 link=1255225763/3#3 date=1255244040
    I had the same problem - used a descaler (not sunbeam) and ran it through the wand - problem fixed. *The sunbeam descaler comes with a warning not to run it through the steam - but I got a commercial descaler which is approved for food devices. *Some of the sponsors sell similar products.

    Hope this helps.
    only run as stated by senator above... The fumes are nasty and can cause major problems... Also be aware that it can loosen crap and it can then get stuck in the steam pump. after that a major manual clean

    from my usless iPhone



Similar Threads

  1. Plunger advice needed
    By Intellidepth in forum Brewing Equipment - Manual Coffee Brewing Processes
    Replies: 19
    Last Post: 8th August 2013, 09:53 AM
  2. Almost there, advice needed
    By notstevieray in forum Brewing Equipment - Entry level (sub $500)
    Replies: 6
    Last Post: 27th September 2011, 07:26 AM
  3. 6910 leaking around group. Advice needed from wise heads.
    By Black_Gold in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 65
    Last Post: 1st January 2011, 05:33 PM
  4. Advice needed
    By TC in forum Brewing Equipment (non-machine specific)
    Replies: 0
    Last Post: 18th February 2007, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •