Results 1 to 3 of 3

Thread: Sunbeam EM6910 Dripping water from PF when steaming

  1. #1
    Junior Member
    Join Date
    Sep 2014
    Posts
    1

    Sunbeam EM6910 Dripping water from PF when steaming

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hey guys got my EM6910 about 2 weeks ago here in the states (rebranded as a Krups machine). You all have been awesome for getting the perfect cup from this machine!!! Only issue I am having is that when I am steaming milk I notice the PF dripping water. It doesn't matter if I cleaned the PF out or if it's not in the group head I still get little drops every couple of seconds. Is this normal?

  2. #2
    Senior Member
    Join Date
    Aug 2013
    Location
    Rockingham W.A.
    Posts
    1,378
    Quote Originally Posted by NuLLKiLL View Post
    Hey guys got my EM6910 about 2 weeks ago here in the states (rebranded as a Krups machine). You all have been awesome for getting the perfect cup from this machine!!! Only issue I am having is that when I am steaming milk I notice the PF dripping water. It doesn't matter if I cleaned the PF out or if it's not in the group head I still get little drops every couple of seconds. Is this normal?
    Hi NuLLKiLL

    I had 2 6910's until recently (only one at present). There are many "quite different" variations within the 6910 range, the 2008'ish ones (mostly) did this out of the box. A qn: is the "red button" on your drip tray round (circular / cylindrical) or a long strip connected by a lever?

    http://coffeesnobs.com.au/brewing-eq...tml#post507441 onwards has a lot more of my posts about 6910's and 480 grinders. Please read them before asking for things I have already written about: that is my actually first CS post...

    I presume your Krups is new? If so, not normal... FYI, no big deal in terms of usage, unless you froth a lot of hot chocs in the jug without pulling a shot.

    Regards

    TampIt

  3. #3
    Junior Member
    Join Date
    Aug 2014
    Location
    Sydney, Australia, Australia
    Posts
    8
    My EM6910 seems to drip a bit of water whenever I steam too. I don't think much about it though.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •