Results 1 to 7 of 7

Thread: EM 6910- 2 Cups button will not stop pouring

  1. #1
    Junior Member
    Join Date
    Oct 2014
    Posts
    2

    EM 6910- 2 Cups button will not stop pouring

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello everyone,

    We have an emergency situation ( not really, but a mum needs her coffee)
    Our coffee machine (prob 5-6 yrs old) SUNBEAM E6910 Cafe Series which has been working well started having issues on the weekend.
    When we push the double cup button (which is the setting we always use) to get the 60ml pour it starts but keeps on pouring until we manually stop it by pushing the button again. Now that I think of it, the pours have also been uneven of late. The machine will pour 60ml the first coffee and then 30ml for the next coffee until the machine is turned off. The machine is due for service, but we can't take it into Sydney until later this week. Is there any tips we could get to make it through the next couple days? The one cup button works but the coffee taste more watery...

    I'm a newbie here, so my "lingo" is most likely not correct, please be kind

    Thanks in advance

    SophieP
    Last edited by sophiep; 13th October 2014 at 08:44 AM.

  2. #2
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    7,049
    Morning Sophie, welcome to Coffee Snobs

    It would help if you give us a bit more information i.e. make and model of machine, then perhaps owners of similar machines may be able to assist.

  3. #3
    Junior Member
    Join Date
    Oct 2014
    Posts
    2
    Sorry Sunbeam EM6910 cafe series

  4. #4
    Senior Member coffeechris's Avatar
    Join Date
    Jul 2011
    Location
    Melbourne
    Posts
    759
    Hi there, I have had a few of these, mainly for the guys at work. I have always bought second hand. That aside I will be honest with how I think you can fix the problem. You said two things the stick out to me. Mum needs her coffee and the machine is verging on 6 yrs old. My advice look at buying another machine if the $$ allows you. For a these to last that long is good but fixing it may not stop other issues arising. You could always take your chance at buying a secondhand one or look at buying a new machine. What ever you do mum needs her coffee.

    Cheers,
    Chris

  5. #5
    Senior Member Yelta's Avatar
    Join Date
    Jun 2009
    Location
    Moonta SA.
    Posts
    7,049
    This thread re the SB 6910 is pretty current http://coffeesnobs.com.au/brewing-eq...-pointers.html why not ask the question there.

  6. #6
    Senior Member
    Join Date
    May 2014
    Posts
    550
    Sophie,
    Welcome, your explanation is clear however, may I have a clarification regarding the use of the manual button for brewing,do you use this to start/stop the brewing?
    Check your instruction manual for resetting the programmable memory and try that for a start,we await your reply
    Cheers
    Mick
    Quote Originally Posted by sophiep View Post
    Hello everyone,

    We have an emergency situation ( not really, but a mum needs her coffee)
    Our coffee machine (prob 5-6 yrs old) SUNBEAM E6910 Cafe Series which has been working well started having issues on the weekend.
    When we push the double cup button (which is the setting we always use) to get the 60ml pour it starts but keeps on pouring until we manually stop it by pushing the button again. Now that I think of it, the pours have also been uneven of late. The machine will pour 60ml the first coffee and then 30ml for the next coffee until the machine is turned off. The machine is due for service, but we can't take it into Sydney until later this week. Is there any tips we could get to make it through the next couple days? The one cup button works but the coffee taste more watery...

    I'm a newbie here, so my "lingo" is most likely not correct, please be kind

    Thanks in advance

    SophieP

  7. #7
    Senior Member
    Join Date
    Aug 2013
    Location
    Rockingham W.A.
    Posts
    1,424
    Quote Originally Posted by sophiep View Post
    Hello everyone,

    We have an emergency situation ( not really, but a mum needs her coffee)
    Our coffee machine (prob 5-6 yrs old) SUNBEAM E6910 Cafe Series which has been working well started having issues on the weekend.
    When we push the double cup button (which is the setting we always use) to get the 60ml pour it starts but keeps on pouring until we manually stop it by pushing the button again. Now that I think of it, the pours have also been uneven of late. The machine will pour 60ml the first coffee and then 30ml for the next coffee until the machine is turned off. The machine is due for service, but we can't take it into Sydney until later this week. Is there any tips we could get to make it through the next couple days? The one cup button works but the coffee taste more watery...

    I'm a newbie here, so my "lingo" is most likely not correct, please be kind

    Thanks in advance

    SophieP
    Quote Originally Posted by mulquemi View Post
    Sophie,
    Welcome, your explanation is clear however, may I have a clarification regarding the use of the manual button for brewing,do you use this to start/stop the brewing?
    Check your instruction manual for resetting the programmable memory and try that for a start,we await your reply
    Cheers
    Mick
    Hi sophiep

    I presume you have the manual? If not, you can download it at SB website:
    https://www.sunbeam.com.au/Root/Spec...M6910_ib_1.pdf

    Try resetting the machine to factory default and see if that fixes it.

    If not, try programming the single button to do a double shot and see if that works.

    Ignore those who said it will wear out, my older one is still going strong (2008) and still makes better coffee than my newer one (2011/2?). The basic mechanism will last a very long time as long as you use good water (rain / filtered / whatever) and keep it reasonably clean.

    Getting it serviced would be a really good idea anyway, as a slow build up of gunk is quite likely.

    Hope this helps

    TampIt



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •