Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By brianleon

Thread: silvia wont steam or give hot water

  1. #1
    Member
    Join Date
    Mar 2007
    Posts
    56

    silvia wont steam or give hot water

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello
    Yesterday I changed the group head seal on my rancilio silvia, it was badly in need of a change and I lay the machine down to remove the old seal. The next shot I produced was ok ,no leaks but when I try to steam I get no pressure(or little pressure)same with hot water, I can hear the pump ok but the water only pours out weakly.
    I cant think what the issue is,coincedence (meaning I have missed something) or is the seal to blame, pump ok boiler ok I am puzzled.
    cheers for any help. Just did a decent shot,hot water from kettle and im ok for coffee but my machine is crook any help appreciated.
    brian

  2. #2
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,689
    Any chance you've dislodged a bit of scale which has settled in an unfortunate location when you returned the machine to the upright position (or perhaps when you had it on its side)?

  3. #3
    Member
    Join Date
    Mar 2007
    Posts
    56
    Hope so Barry ,everything seems operational. Will investigate on weekend in fact when I steam it up light goes on boiler heats up light goes off---no steam out of wand but if I pour a empty shot steam comes out of group head. very strange.

  4. #4
    Senior Member
    Join Date
    May 2014
    Posts
    550
    Hello Brian,
    As Barry was hinting at,descaling would be most worthwhile at this point,next question is how recently have you successfully used a blind basket or similar to back flush your Rancilio?
    The fact you have successfully produced a shot of coffee suggests the above two tasks may get both your Silvia's steam pressure and water flowing again.
    Cheers,
    Mick

  5. #5
    Member
    Join Date
    Mar 2007
    Posts
    56
    Good idea gonna back flush right now.I am seriously at a loss to understand how changing a group head seal can then cause new issues,although the old seal had gone hard ( to long between service I know). Its 10 years old and I use it every day had a few services ,a few seals changed and its never let me down . What a great product may have to buy another.
    mulquemi likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •