Results 1 to 3 of 3

Thread: Em6910 - think the thermoblock is stuffed

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Posts
    16

    Em6910 - think the thermoblock is stuffed

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Tired machine - bought August 2011 so it's done some good miles.

    Collars been done once, brew head seal twice but now it won't heat up at all, both pumps.

    Solenoid issue or something worse?

    Throw it in the e-waste bin or is it still worth repairing? I have a guy I use in Moorooka (Brisbane) who knows these models backwards and as a service agent is excellent.

  2. #2
    Senior Member noidle22's Avatar
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    1,172
    A solenoid wouldn't cause no heat.

    Does the power light just keep flashing green? If so, it's probably the thermal fuse on the steam thermoblock. The fuse can be replaced cheaply but it's a gamble how long it will last if the thermoblock has a problem.
    Thermoblock cost to an agent is fairly cheap (I won't say how much as it could cause problems with your agent and his pricing) and is generally worth doing.

    What do you mean "both pumps"? Both pumps do what? Not work? They won't if the machine isn't in ready mode.

  3. #3
    Junior Member
    Join Date
    Apr 2010
    Posts
    16
    The green power light will just keep on flashing and it makes a clicking noise, but never gets to the "ready" stage.

    It's probably a fuse going on your advice, thanks.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •