Results 1 to 4 of 4

Thread: Tried to start up my old Mokita and getting no water from group head or water

  1. #1
    Junior Member
    Join Date
    Jun 2012
    Location
    Townsville
    Posts
    9

    Unhappy Tried to start up my old Mokita and getting no water from group head or water

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Tried to start up my old Mokita as my BES920 is off for repair. I am getting no water through the group head or water spout...thoughts?
    I can hear the pump and it sounds pretty normal but no water is being pumped into the boiler I am fairly sure...
    Where is the best place to buy parts $$$ and can I repair myself?
    Any help would be greatly appreciated.

  2. #2
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,433
    Do you get water out of the wand of you turn on the water button?

    Sounds like it could be a stuck solenoid?

    Don't leave it on if you think it's not filling the boiler as you will blow the element.

    You can disconnect the boule element while diagnosing. Normal don't touch a plugged in machine disclaimers etc.

    They are a simple machine and if you are a tinkers you should be able to DIY.

    Coffeeparts or jetblack espresso should have parts.

    Cheers

  3. #3
    Junior Member
    Join Date
    Jun 2012
    Location
    Townsville
    Posts
    9
    HI Artman, No water through the wand...was looking up parts at Jetblack but wanted an option, so thankyou...

  4. #4
    Senior Member artman's Avatar
    Join Date
    Jun 2006
    Posts
    2,433
    Have you checked the pump is pumping? Disconnect its output and see if it does, you will probably need to extend it into a container so it doesn't spray everywhere inside machine.

    Cheers



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •