Results 1 to 5 of 5

Thread: Sunbeam EM6910 broken valve (?), help identify

  1. #1
    aik
    aik is offline
    Junior Member
    Join Date
    Dec 2013
    Posts
    18

    Sunbeam EM6910 broken valve (?), help identify

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Our coffee machine in the office stopped working with no warning. I turn the pump on, it makes noise but not coffee. I opened it up, looked with mates and we found what looked as a dismantled flow valve, I took it out - it is made of 3 pieces and resides in the end of the upper hose connected to the _|_|_ -shaped connector. When the pump is on, it can be seen how water flows from the pump down this hose. Jamming this hose with pliers produces quite good coffee (not for long - pressure builds up and the hose jumps off the pump) so I assume other parts are more or less ok.

    There are 2 pictures, one is the whole machine, the second is the spot where the valve is supposed to be and the valve itself disassembled. We think that the right bit of the valve is supposed to have some sort of a head or something, otherwise it just moves through that _|_|_ connector. Why it broke is still open question - pressure or age :-)

    So. The question is - what is this part name/number (to search on ebay) and what is its purpose?

    http://ozlabs.ru/f/IMG_20161004_193437.jpg
    http://ozlabs.ru/f/IMG_20161004_193453.jpg

  2. #2
    Senior Member noidle22's Avatar
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    1,165
    All looks normal there. That part you have pictured is just the joiner from the water tank to the steam pump.
    The hose coming in from the top is from the coffee pump self-priming valve. When this valve is open, water passes through the hose back into the water tank.

    The self priming valve is where your problem is. It's the white fitting attached to the top of the coffee pump.
    It sounds like it has failed internally and is dumping all of the brew water out of that hose pictured.

    You will need a new valve. It's called, as i mentioned, a self priming valve.
    Sunbeam call it the S3 valve for some reason.

  3. #3
    aik
    aik is offline
    Junior Member
    Join Date
    Dec 2013
    Posts
    18
    Thanks for the response. So these 2 white pieces and a spring - these are from "s3 valve", just travelled down the hose?
    Also, google/ebay cannot find neither "sunbeam self priming valve" nor "sunbeam s3 valve", where do people get this stuff?

  4. #4
    Senior Member noidle22's Avatar
    Join Date
    Mar 2012
    Location
    Bathurst
    Posts
    1,165
    Sorry, I didn't notice those parts at the bottom of the photo, I was on my phone at the time. Yes, those are the internals of the self priming valve that would have come down that hose.

    If you send me a message I can supply the part.

  5. #5
    Junior Member
    Join Date
    Apr 2017
    Posts
    26
    Hi noidle22,

    Can the pump primer be purchased as a copper/metal part to match an Ulka EX5? Perhaps other brands using EX5 pumps might have the equivalent in brass?

    Cheers



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •