So my EM7000 steam wand stopped Producing steam and now only water.

after some testing and research on here. i followed the advice below in the Quote.

The thermo block will heat up if just given straight 240v , so thats fine. the Thermal Fuse is fine, i have continuity through the fuse.

the Relay i replaced on the PCB was the one suggested in the post below, ( OJE-SS-112HM,000 | TE Connectivity SPST-NO PCB Mount Non-Latching Relay, 12V dc Coil, 10 A | TE Connectivity), also tested the solder was good , continuity from the new soldiered point to another point on the board in the circuit.

Steam Thermoblock still wont heat up, so I'm at a loss at what i could be. Any one have any idea's for what i could try.

Quote Originally Posted by noidle22 View Post
It was probably the relay on the PCB that I mentioned in a previous post. If the machine is still under warranty, you will void it by doing the repair yourself.

*Disclaimer*
These repairs are intended only if you have experience working with 240V components and soldering. This is undertaken at your own risk.
If you read this and have any concerns, do not attempt the repair and take the machine to an authorised service centre.

If the machine is not under warranty, the repair is simple enough as long as you can solder components to a PCB. The relay is available from RS Components, part number 719-6341. They cost about $2.50 each.

Unplug the machine from the powerpoint.

Remove the plastic base of the machine by removing all visible philips head screws. You will then see the pumps and wiring.

There will be 4, maybe 5, small philips head screws that affix the metal cover plate over the PCB that are undone from the base of the machine.
Once these are removed, pull down on the metal plate and the big white PCB case will be exposed. There's a few more philips head screws that hold the plastic cover over the PCB. remove them to gain access.

Once the PCB is exposed, take a photo or label each wire so you know how to reassemble it.
Unplug everything and remove the PCB.

You will see a row of small black boxes, these are the relays. There will be a spade terminal on the PCB that says steam or steam heater or something like that, I cant quite remember.
Follow the track on the PCB from this terminal and it will lead to one of the relays. This is the relay you need to replace.

Desolder the relay, the new relay will be a direct fit. It can only go in one way due to the pin layout on the relay.
Resolder and reassemble.

Test the machine, it should now work properly.

If you still don't have any steam, possibly the relay failed closed instead of open which means the thermal fuse on the steam thermoblock will have blown.

To remove the top of the machine to access the thermoblock, remove the small lid on top where you access the water inlet and filter basket storage. Squeeze the plastic hinge pieces inwards and the lid will come off.
Remove the 5 or however many it is philips head screws that affix the lid to the plastic housing. There are 2 more screws under the front of the machine that also need to be removed. You can see the 2 access holes by looking up under the front of the machine.
The lid slides forward and up. There will be an earth cable attached to the lid that needs to be removed. Remember to reattach this upon reassembly.
You can rest the lid to the side of the machine without needing to disconnect the red and black wiring harnesses however they can be removed for easier access.

The steam thermoblock is laid out horizontally at the back of the machine. The thermal fuse is the part attached to the thermoblock in the white material shealth with blue wires coming out of it.

This is a 240C rated fuse, available from RS, part number 176-9356. You will need a good quality crimping tool and terminals to crimp multi strand wire to the single pin of the fuse. Do not solder these as it will heat up enough to melt the solder. Ensure that the white material sheath covers all exposed wiring from the fuse and is in good condition. The body of the fuse is at 240V and will short to the thermoblock if there is any damage to that sheath.

Reassemble and test. You should be good to go.