Results 1 to 3 of 3

Thread: Lelit PL042TEMD repair question

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Location
    Melbourne-ish
    Posts
    2

    Lelit PL042TEMD repair question

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all,

    My Lelit PL042TEMD decided yesterday that, while it would happily grind beans, it wouldn't do anything else. No lights (except on the main power switch), no display, no heating, no pump, no steam. Nothing except the grinder. This happened about a year ago (and I'm pretty sure that it's the result of some form of heater element abuse) so I took it to be repaired. The repair shop had it for about a month, and I got a pretty unclear report of what the problem had actually been. As far as I can remember it came down to something like a trip switch that needed resetting. I would really rather not be without it for a month if it's something relatively straightforward that I can fix, but after having a quick look inside I realised that I have no idea what I'm doing. I've had a look around at various guides, but haven't been able to find anything that addresses this particular problem. Does anyone have any ideas about where I should look for the problem, or any online guides that might point me in the right direction? Or should I resign myself to petrol station coffee every morning for the next month?

    Any help much appreciated.

  2. #2
    Senior Member LeroyC's Avatar
    Join Date
    Sep 2013
    Location
    Woodend, New Zealand
    Posts
    2,299
    Where are you based?

  3. #3
    Junior Member
    Join Date
    Apr 2017
    Location
    Melbourne-ish
    Posts
    2
    Adelaide... haven't figured out how to edit my profile yet.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •