Results 1 to 4 of 4

Thread: MeCoffee PID for Gaggia Classic

  1. #1
    Junior Member
    Join Date
    Sep 2018
    Posts
    4

    MeCoffee PID for Gaggia Classic

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello. Has anyone been successful installing the MeCoffee PID on a North American Gaggia Classic? I have installed it successfully and am pulling very, very good shots, but the steam functionality is broken. Basically the boiler just gets hotter and hotter and never regulates the steam temperature. You have to pull the plug out of the wall to keep it from delivering power to the boiler. Very scary. Apparently a fuse will blow if it gets too hot, but so far I haven't had it happen. I think mine got up to about 170 Celcius!

    I did find one post with modifications to support the wiring color scheme for my Gaggia but I don't see any solution for the steam issue other than to take the unused steam thermostat and install it in the boiler thermostat and direct the MeCoffee through it to have the ability to limit the overall temperature to the max of the steam thermostat.

  2. #2
    Senior Member CafeLotta's Avatar
    Join Date
    Jun 2012
    Location
    Melbourne, Vic, Aust.
    Posts
    1,077
    You've probably seen this MeCoffee addendum for the Gaggia Classic but just in case you haven't - https://mecoffee.nl/mecoffee/install...aggia-classic/

  3. #3
    Junior Member
    Join Date
    Sep 2018
    Posts
    4
    I have seen one but not exactly like that, so thanks for sending that link. I had a little bit more success by finding out that I might want to piggyback from the MeCoffee controller #4 to the middle wire on the steam switch. I did get the steam to stay in that 125 Celsius range but after I turned off the steam switch the temperature heads for the skies and I have to pull the power again. I'm going to follow up with Jan at MeCoffee and see what I should do. Thanks!

  4. #4
    Junior Member
    Join Date
    Jan 2019
    Posts
    2
    Quote Originally Posted by brianchi73 View Post
    Hello. Has anyone been successful installing the MeCoffee PID on a North American Gaggia Classic? I have installed it successfully and am pulling very, very good shots, but the steam functionality is broken. Basically the boiler just gets hotter and hotter and never regulates the steam temperature. You have to pull the plug out of the wall to keep it from delivering power to the boiler. Very scary. Apparently a fuse will blow if it gets too hot, but so far I haven't had it happen. I think mine got up to about 170 Celcius!

    I did find one post with modifications to support the wiring color scheme for my Gaggia but I don't see any solution for the steam issue other than to take the unused steam thermostat and install it in the boiler thermostat and direct the MeCoffee through it to have the ability to limit the overall temperature to the max of the steam thermostat.
    I have the same problem with my machine, the elements have 100% power until the temp passes the cut off line 125 however, never the elements arenít backed off, the temp continues to soar.

    The other problem I have is that I canít seem save the settings. After I change some variables, then upload them, close the app and reopen it to find that the settings have reverted back to default. Has anyone else found this problem?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •