Results 1 to 2 of 2
Like Tree1Likes
  • 1 Post By WarrenK

Thread: Breville BES870XL steam not functioning normally

  1. #1
    Junior Member
    Join Date
    Mar 2019
    Posts
    1

    Breville BES870XL steam not functioning normally

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi everyone! Thanks in advance for your kind assistance.
    I've purchased a Breville BES870XL 3 years ago and everything worked perfectly until a few months ago.

    I follow the standard procedure for milk forthing:
    1) before forthing: dial to 'steam' position - pumping sound is heard - steam comes out of the wand ---works fine
    2) forthing: dial to 'Standby' position, insert the wand to the milk, dial to 'Steam' for milk texturing ---- works fine
    3) after frothing: after dialing back to 'standby' and removing the milk jug, i quickly wipe the milk on the wand and dial it back to 'steam' again to push out any milk inside the wand but no steam comes out at this point.

    Though pumping sound is heard, no steam is coming out from the wand. If i turn off the machine or dial it to 'standby' for a few minutes, squeak sound is heard and steam comes out everywhere from the machine. (looks like the machine's releasing the steam that it's holding up)
    Then the steam function can be used again. I never experienced this before and the steam function used to be available whenever i dial it to 'steam'.

    Please advise what i can do to fix this problem and thanks again!

  2. #2
    Senior Member
    Join Date
    Apr 2017
    Posts
    112
    Have you tried cleaning the steam wand, page 27 of instruction book? Use the cleaning tool to unscrew the tip.
    level3ninja likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •