Results 1 to 4 of 4

Thread: EM6910 spurts out back

  1. #1
    Junior Member
    Join Date
    Apr 2019
    Posts
    2

    EM6910 spurts out back

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi all,
    Have an EM6910. If I pack the beans such that the pressure gauge goes beyond half way (not that I'm trying to do that, but if I go too far), then the coffee spurts out the back. This is a newish problem but I've been coping for a few weeks. Is this fixable? I'm guessing a seal has gone somewhere? There's a video here.

    Cheers,
    James

  2. #2
    Senior Member Jackster's Avatar
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    1,018
    First thing is to try cleaning the groove the seal sits in. Remove the screens (and clean them) then the seal and clean the groove. Have a good look up there with a torch as the crud gets real packed up there like tar. You may need to use a wooden tool to scratch it out. Retry your old seal...
    If that doesn't work, new blue silicone seals are available from a site sponsor, or other places.

  3. #3
    Senior Member Jackster's Avatar
    Join Date
    Nov 2017
    Location
    Maddington, Perth. Wa
    Posts
    1,018
    Just putting a new seal in a dirty groove will not stop the leak...

  4. #4
    Junior Member
    Join Date
    Apr 2019
    Posts
    2
    Hi Jackster,
    Pulled it apart and there is indeed a big split in the blue seal. Have ordered a new one and we'll see how it goes.
    Cheers,
    James



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •