Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By level3ninja

Thread: Help with Sunbeam Cafe Series

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Posts
    3

    Help with Sunbeam Cafe Series

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi guys

    I am new to this forum and a coffee machine newbie. I have had a Sunbeam Cafe Series EM7000 for about 12 months and we use it to make between 3-10 coffees most days in our office.

    I had made two coffees in a row this morning and when I went to make the third the machine started malfunctioning. I have uploaded a video to YouTube of what the machine is doing - even after turning it off and then on again it is stuck at this point. The power light turns on but no other lights turn on.

    Video of the problem here -> https://youtu.be/9QqTBWnjP9g

    Does it need to be de-scaled? If so what is the best way to do this? The manual has a few different options, liquid, tablets, vinegar etc.

    Thanks so much in advance for any tips or assistance! I am really worried I have totally buggered it!

  2. #2
    Senior Member level3ninja's Avatar
    Join Date
    Nov 2013
    Location
    Sydney
    Posts
    1,463
    So as soon as you turn it on at the wall this happens straight away or once you hit the power button on the machine?

    Have you ever descaled the machine or done any maintenance?

    What area are you in and what is the water hardness like there? Do you use tap water in the machine?

    I find the vinegar method the cheapest. It does leave a vinegar taste in the machine that you need to flush out with clean water.
    I recently descaled a 7000 that looked like it had never been done. I did 2 or 3 cycles with Cafetto but once it still needed more I switched to vinegar. It took approx 25 descale cycles and then 35 clean water cycles. The way to tell if you've flushed it with water enough is to collect some water from the empty group head in a cup, then put some of the water you fill the tank with in another cup. Once the machine water has completely cooled to room temp taste both cups and compare, if you can detect a difference you need to keep flushing.
    Simplyhuman likes this.

  3. #3
    Member alexm1's Avatar
    Join Date
    Sep 2009
    Posts
    49

    Help with Sunbeam Cafe Series

    If it is running as soon as you turn it on it usually indicates a failed triac, it can be caused by water on the PCB but if there has been no recent work on the machine that is less likely. It is not caused by a build up of scale so cleaning will not help.

  4. #4
    Junior Member
    Join Date
    Aug 2019
    Posts
    3
    Thanks guys, this happens as soon as the power button is turned on, it doesn't happen if it is just sitting plugged in but not switched on. I haven't de scaled it before or done any maintenance beyond basic cleaning.

    Sorry forgot to add we are in Western Sydney Richmond/Penrith area

  5. #5
    Member alexm1's Avatar
    Join Date
    Sep 2009
    Posts
    49
    That is a different problem to the failed triac. It does sound Ike a control board problem however. It is unlikely to be helped by cleaning.

  6. #6
    Junior Member
    Join Date
    Aug 2019
    Posts
    3
    Thank you, is there somewhere I can take it to be fixed or serviced?

  7. #7
    Member alexm1's Avatar
    Join Date
    Sep 2009
    Posts
    49
    I am sure the answer is yes but I am not in Sydney so cannot help with that, sorry.

  8. #8
    Senior Member level3ninja's Avatar
    Join Date
    Nov 2013
    Location
    Sydney
    Posts
    1,463
    Did you buy it new 12 months ago? If so your best bet is to chase it up with your retailer / Sunbeam as a warranty issue.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •