Results 1 to 9 of 9
Like Tree2Likes
  • 1 Post By TC
  • 1 Post By sniferdog

Thread: ECM Mechanika IV not heating water

  1. #1
    Junior Member
    Join Date
    May 2013
    Posts
    5

    ECM Mechanika IV not heating water

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hello Brains trust

    Have a ECM Mechanica that is a couple of years old.

    When we turn it on the pump runs for a lot longer than usual (1 minute +),

    Then the low water light indicats there is no water (it's full) and the pump stops running and the machines doesn't start the heating process.

    Doesn't always play up but will on occasion start ok

    Probably not an easy fix but any help appreciated in advance

  2. #2
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,577
    What water are you putting in the tank?

  3. #3
    Junior Member
    Join Date
    May 2013
    Posts
    5
    I have used filtered water since day 1

  4. #4
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,577
    Quote Originally Posted by sniferdog View Post
    I have used filtered water since day 1
    Filtered by what method? That is my point. This might explain why the machine is not detecting the correct water level.

  5. #5
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    16,619
    Quote Originally Posted by Barry O'Speedwagon View Post
    Filtered by what method? That is my point. This might explain why the machine is not detecting the correct water level.
    May be due to scale buildup on the probe surface if the filtering process is inadequate.... Possibly B.O'S's point.

    Mal.

  6. #6
    Junior Member
    Join Date
    May 2013
    Posts
    5
    ok understand. I've been using a Brita jug filter. I realise this is not ideal however I try to descale every 4 or 5 months. Maybe this is not enough?

  7. #7
    Junior Member
    Join Date
    May 2013
    Posts
    5
    Yes ok. Sounds like the issue. Given this is probably the problem can I locate this and clear or is this a back to base fix?

  8. #8
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    My thoughts are that in all likelihood, you have a combination of issues here. I would advise you have the machine looked at by a professional.

    Descaling? Best not unless you are certain it's required. Should I descale my machine? | Talk Coffee

    We service machines which have been backflushed with descaler, descaled with backflush detergent and fwiw, the overwhelming majority of descale treatments done to machines are either not required or completed incorrectly. Owners frequently do more harm than good.

    Chris
    Dimal likes this.

  9. #9
    Junior Member
    Join Date
    May 2013
    Posts
    5
    Behmor Brazen - $249 - Free Freight
    Chris, Dimal and Barry thanks for taking time with the advice. Very much appreciated
    Dimal likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •