Results 1 to 7 of 7

Thread: EXPOBAR repair question from newbie

  1. #1
    Junior Member
    Join Date
    Jun 2008
    Posts
    3

    EXPOBAR repair question from newbie

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Dear all,

    we are running CREM A.C. S.L. *EXPOBAR OF-P-1GR pulser with grinder machine in Japan in a small foreign coffeeshop.

    After 1 year of use weve got a problem - after switching the machine on the pump starts to run, however the pressure in te boiler does not go up (at least the pressure indicator does not move from zero). Temperature of the boiler does not go up either. Pump is running continuously and does not stop.

    Specific to Japan is that there is no service for such kind of machines and there are no repair shops who can do a custom repair service. Therefore I decided to remember my electrical engineering knowledge and repair the machine by myself.

    My idea is to check if pump is really working (water goes from tank to boiler), then to check if boiler thermostat works properly. If everything is OK, then to check if the boiler pressure sensor is not broken.

    The question is if the boiler is already full, how can I drain it to prevent from overfilling? Is it necessary?
    Can you advise any source for usual algorhytms of checking up such kind of machines?

    Sorry if i ask the question in a wrong forum.

    Thanks in advance!

  2. #2
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: EXPOBAR repair question from newbie

    Valmacha,

    Welcome to CS, well you if not heating up, you have only three choices.

    1. Thermostat
    2. Preasure switch
    3. Heating element ( probably this one)

    Test each of them with the multimeter, you probably find that the element has not any resisten.

    Any more question fill free to call me or pm. You should sendan email to CREM Spain to find out who is the service agent or importer to get the spare parts locally.

    Regards


    Renzo

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Posts
    3

    Re: EXPOBAR repair question from newbie

    Thanks for a quick reply! Tomorow I check tomorrow and reply to you once again. Can you help with spare parts just in case? I dont want to work with japanese companies here.

  4. #4
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: EXPOBAR repair question from newbie

    Valchama,

    Unfortunately, you have different electrical components that us in Australia. But if is the element the Bezzera BZ35 uses the same element, so you can go and see the Bezzera Distributor in Japan, years ago was Kalita Coffee.

    The other option I will call my supplier here in Australia to see if they have part that you need, but first let find the problem.

    Best regard


    Renzo

  5. #5
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929

    Re: EXPOBAR repair question from newbie

    Valmancha,

    Sorry, I got confuse the heating element for the expobar not the same diametre of the Bezzera, is the VBM the one is similar than the Bezzera.

    my apology

    You are better of finding the local distributor in Japan

    Regards

    Renzo

  6. #6
    Junior Member
    Join Date
    Jun 2008
    Posts
    3

    Re: EXPOBAR repair question from newbie

    Hi Renzo,

    I checked thermostat, heater and the pressure sensor. All seem to run OK.

    I disconnected all outgoing tubes from the pump to check if it works. Strange, but even if it emits a normal "pumping" sound, the water does not go through. Do you think that this is a problem of the pump? If its possible Id try to change it. I will send you the photo of the pump with fittings and valves. Pump type is ULKA EX5 120V rating. Can you help me with this?

    Thanx!

  7. #7
    Member
    Join Date
    May 2008
    Posts
    58

    Re: EXPOBAR repair question from newbie

    Try initially drawing water from the gropup, if thats OK and the flow rate looks good...then it could be your autofil solenoid is jammed in the brew position and wont allow the boiler to fill, because the boiler cant fill, the Giemmie Autofill controller will cut the power to the heating element to protect it.

    The solenoid could simply be scaled up and sometimes dismantling and soaking in strong descaler can fix the problem, otherwise buy another one. You can confirm its faulty by applying power to it and seeing what happens



Similar Threads

  1. Expobar Minore II repair
    By bendechrai in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 10
    Last Post: 11th February 2014, 07:13 PM
  2. Expobar Minore Coffee Machine Repair in Perth
    By RobScriv in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 4
    Last Post: 11th June 2013, 09:36 PM
  3. Newbie Question - Expobar Minore / Brewtus IV vs. Breville Dual Boiler
    By coffeefan01 in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 14
    Last Post: 5th February 2013, 01:27 AM
  4. Repair for Expobar Minore
    By needmycoffee in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 5
    Last Post: 6th October 2009, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •