Results 1 to 11 of 11

Thread: ECM GIOTTO NOT HEATING

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Posts
    2

    ECM GIOTTO NOT HEATING

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi,
    I have a 4 year old ECM goitto, it was working perfectly but now wont do a thing except emit a couple of clicks when I turn it on.
    It will pass water when I open the group lever but other then that there is no heat or steam or pressure.
    Any suggestions as to the cause would be awesome. :-? :-?

  2. #2
    Junior Member
    Join Date
    Sep 2011
    Posts
    19

    Re: ECM GIOTTO NOT HEATING

    It may be something as simple as the main relay switch not working.

    Im not familiar with the internals of your machine, but had a machine a while back which had the same issue and it turned out to be the relay.

    Im assuming the water coming out is simply from the mains water pressure and the pump is not engaging.

    As such, I would say that, while it may look to be a big problem, it probably isnt a blown up pump or element, but simply on the incoming electrical side of things. Often, when the element is gone, it will trip the fuse at your mains box.

    Have you taken the sides off for a visual inspection?

  3. #3
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: ECM GIOTTO NOT HEATING

    Quote Originally Posted by 634C465B7D75434947444B474E46220 link=1315883732/0#0 date=1315883732
    Hi,
    I have a 4 year old ECM goitto, it was working perfectly but now wont do a thing except emit a couple of clicks when I turn it on.
    It will pass water when I open the group lever but other then that there is no heat or steam or pressure.
    Any suggestions as to the cause would be awesome. :-? :-?
    Hi Andy and welcome to CS,

    A CS search >>>^^^ will reveal that your question has been discussed here a few times. ;)

    Although it is occasionally an element or a thermal cutout, its most likely to be the element relay on the control board- which will need to be replaced. Have your service bloke rewire to 2010 spec. at the same time.

    Sorry to bring bad tidings* :(

    Chris

  4. #4
    Senior Member
    Join Date
    Aug 2009
    Posts
    469

    Re: ECM GIOTTO NOT HEATING

    circuit boards are repairable if youre handy with small electrical bits!

  5. #5
    Junior Member
    Join Date
    Jun 2010
    Posts
    2

    Re: ECM GIOTTO NOT HEATING

    Thanks for the help on that, I will try the circuit board first and work from there

  6. #6
    Senior Member
    Join Date
    Jun 2009
    Posts
    163

    Re: ECM GIOTTO NOT HEATING

    Hi andydub,
    I just wonder how the story end up?
    Because I have the same problem now for my pre-loved Giotto Premium.
    I wonder if you can share some information.
    Cheers
    Colin

  7. #7
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: ECM GIOTTO NOT HEATING

    It will be the control board

  8. #8
    Member
    Join Date
    Jun 2011
    Posts
    84

    Re: ECM GIOTTO NOT HEATING

    What normally fails on these boards? It it usually the relay only?

  9. #9
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: ECM GIOTTO NOT HEATING

    Quote Originally Posted by 747E6D727E71711F0 link=1315883733/7#7 date=1326441600
    What normally fails on these boards? It it usually the relay only?
    Yep- generally the element relay. There are multiple posts outlining the need to rewire Giotto Premium machines which have black and grey low tension wires running to the pressurestat. Its a job for an authorised tech.

  10. #10
    Senior Member
    Join Date
    Jun 2009
    Posts
    163

    Re: ECM GIOTTO NOT HEATING

    Good news!!!
    Last night before I bring it to the local service, I just open up the case and read the wiring diagnostic figure.
    I found the thermo switch and pressurestat can be the possible faulty part besides the circuit board.
    Therefore, I just have a close look at pressurestat and thermo cut-off switch.

    I know people on this forum have suggest me not to DIY due to some potential lethal accident may happen or I can make the machine worst.

    When I saw the pressurestat, I found the red small thingy is a bit separate than before.
    I assume the mechanism of pressurestat is detecting the pressure then cut off the power connection.
    Then I just kind of push it back.

    Plug the power back then everything back to work!! Horay!!!

    Now I am doing the descaling again, I may order the pressurestat to replace the old one, in case it happen again.

    Thanks for all the help on this thread.
    I will definitely bring it to service once I pass my student scholarship poor life.

    Cheers
    Colin


  11. #11
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: ECM GIOTTO NOT HEATING

    Hi Colin, just to clarify, that is not your pressurestat, its the thermal safety cutout - if it has tripped and needed to be reset, it is because the boiler has overheated, probably when you were taking water out to flush the descaler. You need to be careful about taking too much water out of the boiler. If you expose the element to air while it is heating, its very easy to damage it.



Similar Threads

  1. help!! giotto not heating and no pressure.
    By moey007 in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 5
    Last Post: 9th November 2009, 10:53 PM
  2. The sin: ran Giotto out of water. Not heating
    By 51mondays in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 14
    Last Post: 23rd October 2009, 10:20 PM
  3. Giotto not heating :-(
    By steve in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 3
    Last Post: 13th October 2008, 01:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •