Results 1 to 8 of 8

Thread: No water from group head

  1. #1
    Member
    Join Date
    Feb 2012
    Location
    Perth
    Posts
    46

    No water from group head

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    No water will come out of the group head of brugnetti viola* when under full pressure 1.3 bar :(. The machine will trun on and the vibratory pump will kick in as per normal and when it reaches full pressure it automatically cuts out. Before it cuts out the steam and water spout still work but not the group.
    Any thoughts?
    Im thinking its a sensor/eletrical issue

  2. #2
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: No water from group head

    So does the pump switch on at all when you lift the lever?

    I am right in thinking this is an E61 manual lever group machine? Never seen a Viola before, but it should work the same as all other domestic E61 groups, ie. when you lift the lever you open the 3-way valve in the group, and it also activates the pump via a microswitch.

    If theres not even a dribble coming from the group and the pump is running, then therell be a serious blockage internally and youll most likely have to start taking pipes off to find it.

    I would first take off the big nut on top of the group and see if theres any evidence of scale. If there is, that will be the culprit but the blockage could be anywhere.

  3. #3
    Member
    Join Date
    Feb 2012
    Location
    Perth
    Posts
    46

    Re: No water from group head

    Yes its an e61 leaver machine, the pump doesnt turn on when the leaver is pulled and a small amount of water comes out of the group under no pressure
    thanks

  4. #4
    Site Sponsor coffee_machinist's Avatar
    Join Date
    Jun 2011
    Posts
    683

    Re: No water from group head

    Okay first thing, is the lever actually pressing the switch properly? On the front panel, behind the lever there is a cam that pushes the switch. Check that its pushing it in all the way.

    If that doesnt work then there is an electrical fault, something on the control board because if you say the pump is activating to fill the boiler the controller relay is OK, it must be something to do with the brew switch circuit.

  5. #5
    Member
    Join Date
    Feb 2012
    Location
    Perth
    Posts
    46

    Re: No water from group head

    Just had a look at the switch and nothing wrong there so as you said must be brew switch circuit

  6. #6
    Senior Member Koffee_Kosmo's Avatar
    Join Date
    Apr 2008
    Location
    Brisbane
    Posts
    5,113

    Re: No water from group head

    Supplementary question
    Is the* switch that the lever cam activates, pressed in all the way so it is actually making a circuit contact when pressed


    This is what it looks like

  7. #7
    Senior Member
    Join Date
    Mar 2008
    Posts
    554

    Re: No water from group head

    You can test whether water is getting to the group by removing the top nut on the group. Put a towel over the top and start the pump. Water should flow out the top of the group. If it does then look into the top of the group with the nut off and see if the screen (if present) is not clogged and the gicleur (jet) in that hole is not clogged.

    If water does come out then there is a problem with the brew valve in the group. Remove the other top nut (the second , larger one closest to the group) and remove the spring. With the machine off and cool, push down on the valves stem in the hole in the group and lift the brew lever. You should feel the valve being lifted up.

    If no water comes out then the problem might be a solenoid that directs and controls water flow to the HX circuit.

  8. #8
    Member
    Join Date
    Feb 2012
    Location
    Perth
    Posts
    46

    Re: No water from group head

    [QUOTE=1B3F363635350F1B3F233D3F500 link=1331793987/5#5 date=1331815544]Supplementary question
    Is the* switch that the lever cam activates, pressed in all the way so it is actually making a circuit contact when pressed


    This is what it looks like
    [/quote
    Sorry couldnt open your link



Similar Threads

  1. Silvia Problem - No water through group head
    By bloop in forum Brewing Equipment - Midrange ($500-$1500)
    Replies: 9
    Last Post: 16th May 2008, 05:09 PM
  2. water flow rate out of group head
    By andrewT in forum General Coffee Related...
    Replies: 3
    Last Post: 8th May 2008, 11:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •