Results 1 to 5 of 5

Thread: Giotto Slow to Brew

  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    19

    Question Giotto Slow to Brew

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Can anyone give some pointers please?
    My Giotto has become slow to start the brew process: maybe 5 seconds from when the pump starts until the actual infusion process. With a blank filter, the flush is almost instantaneous.
    The slowness is the same whether or not there is coffee in the basket. Once everything is running, the output is OK and I am meeting my 25 seconds target OK.
    I am baffled...its almost as though there is a 'loss of prime'.
    Actually, it has been six years now without any strip-down so I am researching what parts to order ready for an overhaul by way of preventative maintenance. I just would like to understand what is going on first.
    Many thanks.....

  2. #2
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Most likely heat exchanger stall.

    As a start, I'd be replacing the group piston seals and probably the pistons as well. At this age, the cam will need to be checked for wear and may require a tidy up and/or replacement as well.

    In a service, we'd check and attend to a whole heap of other items as required.

    Chris

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    19
    Thanks Chris. It sounds like the time for professional help is approaching!

  4. #4
    Junior Member Squidhead's Avatar
    Join Date
    Mar 2013
    Location
    Adelaide
    Posts
    6
    My last machine was a Giotto made by ECM and it worked well for over seven years.

    Please confirm that you also descale the boiler and remove the shower screen from the Group for cleaning?

    Below is what happens when you leave the Portafilter on the Group for too long without regular servicing.


  5. #5
    Junior Member
    Join Date
    May 2007
    Posts
    19
    Yes, I do descale (but not very often!).
    Yes, I do from time-to-time remove the screen. But It has always been pretty perfect and the gasket has gone hard, but is intact OK. I do use my blank basket before shutting down every time without fail. And I never leave the basket on the machine when it is turned off.
    Following Chris's advice, I had a detailed look and it was a valve seal that was breaking down. I 'bit the bullet' and did a fairly major overhaul, changing a range of parts including the screen and gasket, jet filter, group jet, valves etc. The parts were just over $100 but I hope that I have bought myself a number of years ongoing reliability! I got the parts from 'coffeeparts': ordered them one afternoon and received them the next morning!
    I see value in maybe going to Chris next time and getting an expert eye on the machine....but am happy for now and the ECM is going 'like new;.



Similar Threads

  1. ECM Giotto - Cant adjust brew pressure
    By jkarlis in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 11
    Last Post: 27th March 2010, 05:22 PM
  2. Giotto Premium Brew Temp Low
    By kcstueber in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 5
    Last Post: 26th January 2010, 01:05 PM
  3. Giotto Brew Temp
    By mcknightp in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 1
    Last Post: 16th June 2008, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •