Results 1 to 4 of 4

Thread: New flowmeter not working... Please Help!

  1. #1
    Junior Member
    Join Date
    Mar 2015
    Posts
    3

    New flowmeter not working... Please Help!

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hey guys,

    I'm new to the site, and love the community feel in what I've read so far!

    So here's hoping you can help me out...

    I have a Grimac 2 group compact. Recently had the right group buttons flash during extraction. Extraction happens fine, no problems with flow nor quality, but the flashing buttons meant the pull wouldn't stop. Even when using continuous flow, the button would flash.

    I took this to mean the flowmeter needed replacing, which I confirmed with a tech that I bought some new group head seals from. Note that the original flowmeter is a non-LED type, however when I took it off the machine and dismantled it, the impeller seemed to be moving freely, so I assumed it was an electronic issue with the flowmeter. The new flowmeter I got has a LED indicator on the electronics.

    So I have installed the new flowmeter and the LED on it pulses when there is water moving through it, however I still get the same symptoms at the buttons (flashing light, not cutting off at the end of an extraction). I changed the button pads around (swapped them between the two groups) and same issue on the same flowmeter. I even tested the continuity of the OUT wire from the flowmeter to the control box under the drip tray and that seems to be in tact.

    Is there a diagnostic I can run using a multimeter regarding voltage/current output from the OUT terminal of the flowmeter? Or any diagnostic at all for that matter? This seems to be my missing link, as the flowmeter is powered up and moving freely, just seems not to be communicating with the button pad.

    Any help would be greatly appreciated!

    TIA.

  2. #2
    Senior Member
    Join Date
    May 2014
    Posts
    547
    dzamit85,
    Seems you have had a real determined go with your fault finding,good on you.
    Rather then remain stuck,try swapping over the flow meters as well,if you have a dud flow meter it shouldn't cooperate while connected to second group head line either.
    If it operates normally,you problem is back on your pcb board,may have to check for loose connections of suspect components, good luck.
    Cheers,
    Mick.

  3. #3
    Junior Member
    Join Date
    Mar 2015
    Posts
    3
    Thanks for the response Mick,

    I was trying to avoid that to be honest (electrics i like... plumbing, not so much). But you're right, may be the only way to really nail where the problem lies.

    Thanks again mate, hopefully I'll be able to give this a go tonight.

    Cheers.

  4. #4
    Junior Member
    Join Date
    Mar 2015
    Posts
    3
    Ok so turns out I need an additional right angle connector that was not supplied with the new flow meter. My original flow meter had 3 pins at 90degree angles that were connected with 3 electrical clips. The new flow meter has much smaller, straight pins, and tonight I noticed a small brass thread in the middle of them, which led me to think that there may need to be some sort of a connector that screwed in once it was connected. Which looks like is exactly the case (thank you google!)

    So my question for the CoffeeSnobs community is: If I source the right angled connector (picture linked below), will I be able to wire it up and plug it in to the new flow meter or will I need to start from scratch?

    I have also linked to a photo of my original flow meter for reference.

    Cheers guys.

    P.S, Mick, I took your advice and swapped the flow meters around, and as suspected, the new one didn't cooperate with the group head that I moved it to, and the old flow meter worked perfectly on its opposite side.

    My original flow meter: http://i1303.photobucket.com/albums/...sthkaadt3.jpeg
    Right angled connector: http://i1303.photobucket.com/albums/...psgkcquula.jpg



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •