Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By djk

Thread: Request for help with Isomac Mondiale repair

  1. #1
    djk
    djk is offline
    Junior Member
    Join Date
    Jun 2010
    Posts
    8

    Request for help with Isomac Mondiale repair

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi All,

    I am a proud owner of an Isomac Mondiale that is several years old now and has given comparatively good service so far (I do have some complaints but they can wait for now and another post).

    Just today I went to make the lunchtime coffee and after a while I heard steam start to leak from the overpressure valve. It looks like the machine is not turning off the heating element (the light stays on and the pressure gauge says it is high).

    I have the exploded part view, but that is not completely helpful. I intend to fix it myself, but would love to hear from anyone who can help me with:

    a) experience with this machine with this type of problem
    or
    b) wiring diagrams for the Isomac Mondiale to help me diagnose the problem
    or
    c) details/schematics of the controller to assist me repairing it (if it is involved in this problem)
    or
    d) general description of the operation of the machine in this area to confirm I'm guessing along the right lines.

    My guess so far is that either:
    a) there is a pressure switch that has failed and is therefore not telling the heating element to turn off (does this go through the controller or is it simply wired in series with the heating element?)
    or
    b) if the controller is at all involved, then itself has failed in either the input or output of the above signals
    or
    c) there is a relay to drive the heating element that is stuck on when it shouldn't be

    Aside from this rather disconcerting problem the machine still works and as long as I'm there controlling the on/off switch to get the temperature right I can make a coffee, but of course it's not a long term solution

    Thanks in advance for anyone who can help me with any information they might have.

    Cheers,
    djk
    Last edited by djk; 11th July 2015 at 05:27 PM.

  2. #2
    Mal Dimal's Avatar
    Join Date
    Oct 2004
    Location
    Warwick, QLD
    Posts
    16,771
    G'day mate...

    More than likely it will be related to the Pressurestat in some way. Either the switch/relay contacts are fused together, or there is some kind of physical restraint that is preventing the p/stat from operating as it should. Either way, a new p/stat wouldn't be a bad idea after several years of use, it may be getting a bit tired...

    Mal.

  3. #3
    djk
    djk is offline
    Junior Member
    Join Date
    Jun 2010
    Posts
    8
    OK, thanks Mal, you are right - the pressurestat switch output seemed to be 'stuck' on. This is item 63 in the Exploded View and Parts List I posted in the documentation section

    I adjusted the screw up and down and back to its original position and the function of the on-off cycling returned to normal with pressures turning on at about 1.1 and off at about 1.3 bar. But now I know it is potentially dodgy I'll have to monitor it closely and perhaps order a new one if any misbehaviour recurrs.

    I case it helps, I'm also taking the opportunity to do a descale as a precautionary measure as I write this...
    Dimal likes this.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •