Results 1 to 2 of 2

Thread: Bezerra Galatea Pump/Heating fault

  1. #1
    Junior Member
    Join Date
    Jul 2015
    Posts
    1

    Question Bezerra Galatea Pump/Heating fault

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi Guys,

    I've been a very happy owner of my Galatea for about 4 years now, but in the past few months it's been giving me a little grief.

    It started when I first turned the machine on, the pump would stay on for around 30 seconds, but heated up normally and everything worked OK.

    It progressed a few months later where the heating element would turn itself off after about a minute, but if i switched the machine off and on again, it would heat up fine and work normally. (pump still ran too long though)

    Now, a few months further on again, the heating element switches off immediately when i turn the machine on, and it doesn't get hot at all.

    Shipping it is a real pain, so is it worth opening up and taking a look around or just bite the bullet and send it in.

    Thanks,
    Glen.

  2. #2
    Site Sponsor
    Join Date
    Aug 2006
    Posts
    929
    Hi Glen;

    to have a look is very easy, 4 allen screw on the top of the machine and you can have a look. The question is can you find the problem. For what you describe can be few things this is from the top of my head:
    1 Pressure switch is gone (check the pressure switch with the multi-meter)
    2. Heating element gone (check the pressure switch with the multi-meter)
    3. safety thermostat from the bottom of the boiler has pop up (re set and check it with the multi-meter)
    4. Control board is playing up due to over heating

    I will probably recommend that you send the machine for a general service and them repair

    Regards

    Renzo



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •