Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By flynnaus

Thread: Rocket Giotto pressure problem

  1. #1
    Member
    Join Date
    Sep 2012
    Posts
    73

    Rocket Giotto pressure problem

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Hi there. I need some advice re Rocket Giotto . This morning I turned the machine on , heated up fine but there's no boiler pressure. Turning the machine on and off didn't do anything. Any suggestions please.

    Cheers

    Nelson

  2. #2
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,615
    Not 100% sure what 'heated up fine by there's no boiler pressure' means (i.e. there's no steam? or the gauge just isn't moving or what?) Could be false pressure if valve is sticking. Try opening the steam valve, letting any steam out, then (leaving steam valve fully open) turn off, turn back on again 15 or more minutes later. Someone else will have a better idea than me.

  3. #3
    Senior Member
    Join Date
    Dec 2006
    Location
    Perth WA
    Posts
    572
    Experts will chip in.
    You believe the boiler did heat up? You presume there was water in the boiler? Did you get hot brew water when you lifted the extraction lever. That would prove the boiler did heat up. If it did I expect it was the anti vac valve not releasing the vacuum in the boiler which was created when the boiler cooled from last use - I don't quite understand this. If it was cold then it suggests the switches in the module are faulty.

  4. #4
    Member
    Join Date
    Sep 2012
    Posts
    73
    yes sorry my bad, the machine is warm,but not up to operating temp

  5. #5
    Member
    Join Date
    Sep 2012
    Posts
    73
    yes there was warm water from head when I lifted extraction lever. no steam, no water out of tap.

  6. #6
    Senior Member flynnaus's Avatar
    Join Date
    May 2008
    Location
    Sydney
    Posts
    4,081
    It might be something as simple as a dodgy pressure stat but it requires qualified diagnosis. If it was my machine I would be talking it to a skilled coffee machine technician and consider it getting serviced professionally while it's there.

  7. #7
    Member
    Join Date
    Sep 2012
    Posts
    73
    ok, so I just turned the machine on with the steam valve and water tap open. It actually made pressure. it's working fine ATM . I can hear the odd hiss though. is that the anti vac valve ??

  8. #8
    Senior Member Barry O'Speedwagon's Avatar
    Join Date
    Dec 2011
    Location
    PRL
    Posts
    2,615
    Quote Originally Posted by kike10 View Post
    ok, so I just turned the machine on with the steam valve and water tap open. It actually made pressure. it's working fine ATM . I can hear the odd hiss though. is that the anti vac valve ??
    Sounds like it (i.e. sounds like the problem this time was a sticking valve). Not sure about the hiss....could be the pressurestat. Probably time for a service when you can book it in. One of the experts will undoubtedly see this and comment.

  9. #9
    Member
    Join Date
    Sep 2012
    Posts
    73
    thanks all for your quick response. Hopefully it's just a sticky valve .

  10. #10
    Senior Member flynnaus's Avatar
    Join Date
    May 2008
    Location
    Sydney
    Posts
    4,081
    Yep. The hiss is the anti vac valve. I'd still be taking it in for a service but I wouldn't be surprised if the antivac is replaced (it only costs about $13).
    Dimal likes this.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •