Results 1 to 12 of 12

Thread: ecm giotto problem

  1. #1
    Senior Member
    Join Date
    Apr 2007
    Posts
    390

    ecm giotto problem

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    I was just backflushing my giotto when all of a sudden something went wrong.
    I get no water coming out of the group head now and it also seems the pump may have died as when i normaly works its loud but now i only hear a slight noise when its running, or trying to run.
    Any tips? or how do i know for sure its the pump?

  2. #2
    Senior Member Dennis's Avatar
    Join Date
    Feb 2007
    Posts
    4,512

    Re: ecm giotto problem

    No offense meant John, but did you check the water level and that the reservoir is in place correctly?

  3. #3
    Senior Member
    Join Date
    Apr 2007
    Posts
    390

    Re: ecm giotto problem

    Dennis, no offense taken mate
    yes checked the reservoir and it was still 3/4 full and sitting in place correctly.
    I pulled it out and put it back in place to be 100% sure.

  4. #4
    Senior Member Dennis's Avatar
    Join Date
    Feb 2007
    Posts
    4,512

    Re: ecm giotto problem

    John, if you happen to live in Sydney I recommend you give Di Bartoli a call and speak with Renzo. If youre in Melbourne then 2mcms your man.

  5. #5
    Senior Member
    Join Date
    Apr 2007
    Posts
    390

    Re: ecm giotto problem

    i think i have a poltegeist at home.
    Turned the machine off after it happend.
    Let it cool down and just went to take the top pannel off to have a look inside for any obvious faults.
    Not that i knew what i was looking for, but just incase a hose come off or something.
    Couldnt find anything, so put the lid back on, put the water reservoir back in, fired it up and guess what.

    Yep the pump started working as per normal.

    Maybe she had a hissy fit :)

    Thanks for the help though Dennis, and yes, if it happens again, i think it will be going straight to 2mcm for a service

  6. #6
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: ecm giotto problem

    Hi John,

    A few things can cause this....Give me a buzz if you want to discuss...

    regards

    Chris

  7. #7
    Senior Member
    Join Date
    Apr 2007
    Posts
    390

    Re: ecm giotto problem

    Thank you Chris
    will give you a call tomorrow morning

  8. #8
    Senior Member ozscott's Avatar
    Join Date
    Jun 2006
    Location
    BRISBANE
    Posts
    1,998

    Re: ecm giotto problem

    Given that some of us pine after big shiny expensive machines...can the "few things that can cause this" be summarised on the forum...I (and I guess other too) am building up a store of info about these high end machines...so when the time comes to upgrade I know a bit more about whats what.

    CHEERS

  9. #9
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665

    Re: ecm giotto problem

    Quote Originally Posted by ozscott link=1181123403/0#7 date=1181182880
    Given that some of us pine after big shiny expensive machines...can the "few things that can cause this" be summarised on the forum...I (and I guess other too) am building up a store of info about these high end machines...so when the time comes to upgrade I know a bit more about whats what.

    CHEERS
    Scott- It is normally too clean or too dirty water. Distilled or over filtered water has little ionic content = no conductivity and machine thinks its empty= Safety cutout to protect the element. If grotty water coats the tank probe with scale or causes oxidation, same problem. RO water causes the same issues if not modified ala Veneziano style. RO unmodified = Machine Killer...

    A heap of flusing of both HX and boiler is required after descale as residual gunk can be found pretty much everywhere and this can lead to gremlins.

    We recommend only filtered, softened water in all of our machines- so descaling should be pretty much unneccessary....

    Chris

  10. #10
    Senior Member
    Join Date
    Apr 2007
    Posts
    390

    Re: ecm giotto problem

    once again thanks for all your help Chris

    ozscott, have no fear in purchasing these machines. In over 3 years, appart from this and another incident which was totaly my fault, i have had no major issues. They are bullit proof.
    When the time comes and the ecm goes to coffee heaven (which shouldnt happen for a very long time) i wouldnt hesitate to purchase another one

  11. #11
    Senior Member ozscott's Avatar
    Join Date
    Jun 2006
    Location
    BRISBANE
    Posts
    1,998

    Re: ecm giotto problem

    thanks very much gents....again great forum

    Cheers

  12. #12
    Bon
    Bon is offline
    Senior Member
    Join Date
    Nov 2006
    Posts
    173

    Re: ecm giotto problem

    ^^ I agree, my ECM is solid as a rock.



Similar Threads

  1. After service problem - Giotto
    By norden in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 12
    Last Post: 19th August 2011, 11:36 PM
  2. ECM Giotto Problem
    By venno in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 3
    Last Post: 29th April 2010, 02:26 PM
  3. Giotto Problem
    By farmroast in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 11
    Last Post: 20th March 2009, 01:09 AM
  4. Problem with Giotto
    By bolb in forum Brewing Equipment - Pointy End ($1500-$3000)
    Replies: 11
    Last Post: 6th April 2007, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •