Results 1 to 7 of 7

Thread: Rocket evolution pump issue - I think - HELP

  1. #1
    Junior Member markrcrossman's Avatar
    Join Date
    May 2016
    Posts
    4

    Rocket evolution pump issue - I think - HELP

    Gene Cafe Coffee Roaster $850 - Free Beans Free Freight
    Cleaned my machine this morning and after putting screen back on it won't draw water into the pump. Turn machine on and pump primes but keeps making noise like it's trying to fill up but won't.

    Green light then flashes. And it tries again continuously.

    Any thoughts?

    Pull lever up for a shot and it does the same thing

  2. #2
    Junior Member
    Join Date
    May 2014
    Posts
    9
    Does the tank come out, if so did you put it back in properly?
    Sounds like a water supply issue

  3. #3
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Check that it wasn't accidentally switched to plumb mode.

  4. #4
    Junior Member markrcrossman's Avatar
    Join Date
    May 2016
    Posts
    4
    Tried both. Bubbles come into tank when it's priming.

  5. #5
    Junior Member markrcrossman's Avatar
    Join Date
    May 2016
    Posts
    4
    Can use hot water but not the group head. Could the water pipe have. A blockage possibly? As an alternative question, any recommendations for rocket repairers or services in Perth?

  6. #6
    TC
    TC is offline
    .
    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    14,665
    Don't drain the boiler of hot water while the machine is on in this state as you could cook the element. Best turn it off.

    Service tech required. Dimattina Coffee in Osborne Park sell and service Rocket.

  7. #7
    Junior Member markrcrossman's Avatar
    Join Date
    May 2016
    Posts
    4
    Seems to have fixed itself overnight weirdly enough..



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •